USB microphone problems

Oliver Fromme olli at
Tue Apr 12 14:40:32 UTC 2011

Sorry for posting to both usb@ and multimedia@, but I'm not
sure if the problem is related to usb(4) or snd(4).

I'm trying to get the microphone of a webcam working (it's
a Logitech C210).  When I load snd_uaudio(4), it is found
as follows:

   uaudio0: <vendor 0x046d product 0x0819, class 239/2, rev 2.00/0.10, addr 2> on usbus3
   uaudio0: No playback!
   uaudio0: Record: 48000 Hz, 1 ch, 16-bit S-LE PCM format
   uaudio0: No midi sequencer
   pcm5: <USB audio> on uaudio0

Interestingly, I got only a new mixer device, but no new
dsp device:

   crw-rw-rw-   1 root  wheel       0, 144 Apr 11 22:39 mixer5

And /dev/sndstat says this ("pcm5" is the cam's microphone):

   FreeBSD Audio Driver (newpcm: 32bit 2009061500/i386)
   Installed devices:
   pcm0: <HDA ATI RS690/780 HDMI PCM #0 HDMI> (play)
   pcm1: <HDA Realtek ALC892 PCM #0 Analog> (play/rec) default
   pcm2: <HDA Realtek ALC892 PCM #1 Analog> (play/rec)
   pcm3: <HDA Realtek ALC892 PCM #2 Digital> (play)
   pcm4: <HDA Realtek ALC892 PCM #3 Digital> (play)
   pcm5: <USB audio> (rec)

And finally, mixer -f /dev/mixer5 says:

   Mixer vol      is currently set to  75:75
   Mixer pcm      is currently set to  75:75

There seems to be no recording source configured:
"mixer -f /dev/mixer5 recsrc" produces no output.  Also,
I cannot set any recording source.  But I guess that's OK
because there really is only _one_ fixed recording source
supported by that device.

Strangely, after a few minutes, a dsp device appeared.
Something must have triggered that, but I have no idea what.
Maybe it just took that long because something hung inside
the driver and finally ran into a timeout ...  But that's
just a guess.

   crw-rw-rw-   1 root  wheel       0, 145 Apr 11 22:48 dsp5.0

However, the device doesn't work.  When I tried to do a
test recording with skype, nothing got recorded, and the
following was logged:

   pcm5: chn_read(): pcm5:virtual:dsp5.vr0: record interrupt timeout, channel dead

Does anyone have an idea what to do to get it working?
I'm running a fairly new FreeBSD/i386 8-stable (2011-03-19).

Alternatively, any recommendation for a new USB microphone
to buy that works well with FreeBSD 8?

(By the way, I tried connecting an old analog microphone to
my mainboard's mic input, but it records only silence,
except when I blow directly into the microphone, no matter
what mixer settings I've tried.  So I guess that that mic
input of my mainboard doesn't work correctly with FreeBSD

Best regards

Oliver Fromme, secnetix GmbH & Co. KG, Marktplatz 29, 85567 Grafing b. M.
Handelsregister: Registergericht Muenchen, HRA 74606,  Geschäftsfuehrung:
secnetix Verwaltungsgesellsch. mbH, Handelsregister: Registergericht Mün-
chen, HRB 125758,  Geschäftsführer: Maik Bachmann, Olaf Erb, Ralf Gebhart

FreeBSD-Dienstleistungen, -Produkte und mehr:

"anyone new to programming should be kept as far from C++ as
possible;  actually showing the stuff should be considered a
criminal offence" -- Jacek Generowicz

More information about the freebsd-multimedia mailing list