webcamd/pwcview report

Milan Obuch freebsd-multimedia at
Tue May 4 21:03:25 UTC 2010

On Thursday 29 April 2010 08:41:55 Milan Obuch wrote:
> Hi,
> today I tried webcam support on my MSI Wind U100 netbook. I just did
> cd /usr/ports/multimedia/webcamd
> make install clean
> cd /usr/ports/multimedia/pwcview
> make install clean
> kldload cuse4bsd
> /usr/local/etc/rc.d/webcamd onestart
> pwcview
> and it just worked. Big thanks to Hans Petter who made this possible. I was
> able to test with both internal webcamera and small external camera:

[ snip ]

> There is one issue in my case: I tested it under console, and after
> pressing 'q' display remains dark. No output seen there any more, but I can
> blindly type 'pwciew' and image from webcamera is there again. Card used
> there is
> vgapci0 at pci0:0:2:0:     class=0x030000 card=0x01101462 chip=0x27ae8086
> rev=0x03 hdr=0x00
>     vendor     = 'Intel Corporation'
>     device     = 'Mobile 945 Express Chipset Family'
>     class      = display
>     subclass   = VGA
> Also, I would like to run pwcview or something similar remotely, maybe over
> ssh connection. No success now, just cleared screen. If someone has any
> advice, I am all ears.

Some more testing done, just after upgrade to new version of webcamd and 
cuse4bsd in ports, but for this it seems not to be relevant.

I discovered there is a problem with pwcview when run from console using 
graphics mode, at least with some VESA resolution. After pressing 'q' picture 
disappears, but I found no way how to return into normal shell, even after 
webcam disconnect. When tested with my MSI Wind on console with standard 
25x80 text screen it exits after pressing 'q', but waits until I disconect 
webcam (internal via hotkey, external pulling out of port). Then I can work 
again normally.

I tried it on Compaq/HP TabletPC TC1000, but pwcview does not work here. With 
this VGA

vgapci0 at pci0:0:5:0:     class=0x030000 card=0x00b50e11 chip=0x011210de 
rev=0xb2 hdr=0x00
    vendor     = 'Nvidia Corp'
    device     = 'GeForce2 Go / MX Ultra (NV11)'
    class      = display
    subclass   = VGA

it just initializes webcam (used the same external one), green LED is on, but 
program halts with message 'SDL Failed to set videomode: Unable to switch to 
requested mode'.

On TC1000 I tried also run pwcview from X. This did not work. All I got was 
three lines:

Webcam set to: 320x240 (sif) at 5 fps
libv4l2: error dequeuing buf: Device not configured
Error readingfrom webcam: Device not configured

No idea what could be done here, either.

One more system I can test this has the following:

vgapci0 at pci0:1:0:0:     class=0x030000 card=0x81291043 chip=0x31081106 
rev=0x01 hdr=0x00
    vendor     = 'VIA Technologies Inc'
    device     = 'Via Unichrome S3 VGA - part of a VIA Northbridge (Unknown)'
    class      = display
    subclass   = VGA

Here it works a bit better - while it does not work with graphics mode, it 
does work with standard 25x80 text screen and after pressing 'q' exits 
correctly. Tested with both 8-STABLE and 9-CURRENT under i386 and amd64 

I tried to run pwcview remotely over ssh (from X), but all I got is

Webcam set to: 320x240 (sif) at 5 fps
Failed to create yuvoverlay: Can't use YUV data on non 16/24/32 bit surfaces

As written in first mail, if someone could help me to understand these issues 
or knows something I can use remotely instead of pwcview, I would like to 
test it.


More information about the freebsd-multimedia mailing list