Rainer Hurling rhurlin at
Tue Mar 23 22:29:05 UTC 2010

On 20.03.2010 22:56 (UTC+1), J. Altman wrote:
> I believe this is the best list to start; please feel free to point me
> elsewhere if elsewhere is better.
> First, my environment:
> FreeBSD 8.0-RELEASE-p2 FreeBSD 8.0-RELEASE-p2
> #0: Wed Mar 17 22:12:19 EDT 2010
> root at  amd64
> This is a new install of 8. I am running Grip under Xfce.
> It looks like the Makefile for Grip was updated recently:
> # $FreeBSD: ports/audio/grip/Makefile,v 1.88 2010/02/05 11:34:13
>    dinoex Exp $
> Also, Grip is at version 3.3.1 on Sourceforge, and at version 3.2 in
> the ports tree. I have no clue if a version bump in the ports is
> indicated; or if a new port, grip-devel, is even close to a good idea.
> I use a Grip config file set that worked on my last PC; and it was an
> multi-core Intel box, and the Makefile I used for that pre-dates the
> current one by about one year. I've tried using whatever defaults the
> new installation of Grip offers; no joy there.
> The failure:
> Grip will rip a WAV file using cdparanoia, which is the default ripper
> for Grip. The WAV is not damaged, AFAICT; it plays fine in XMMS.
> Sometime after Grip finishes ripping the WAV file, Grip either:
> 1) immediately crashes and dumps core
> OR
> 2) starts to encode the WAV file to FLAC (or MP3, using LAME) and then
>     crashes and dumps core.
> I suspect 1, since no FLAC file appears in the relevant directory.
> Grip is not tripping over ID3 tags, since "only tag files ending in
> .mp3" is checked in the ID3 configuration tab.
> Grip uses this:
> /usr/local/bin/flac -V -o %m %w
> FLAC works from the command line on the WAV files; so I believe it is
> not a FLAC issue.
> I've searched quite a bit, and can't find any clue regarding the
> issue; is it Grip? is it some deficiency in what Grip needs vis-a-vis
> Gnome 2? Is it something lacking and relevant to the AMD platform?
> Maybe it's simply that Grip is no longer maintained? There is a fork
> of Grip called MP3Mesa: so
> maybe that is what is needed.
> Questions:
> Is anyone here using Grip, on any platform, but especially AMD64?

Yes, grip on very recent 9.0-CURRENT (amd64) with cdparanoia and lame 
for coding. Works fine with the following parameters:

cdparanoia '/path to mp3/%A/%d/%t__%n.wav', no other options;

lame '/path to mp3/%A/%d/%t__%n.%x', options '-h -b %b %w %m'.

> Does anyone have a recommendation for a replacement? I've not seen
> one in the ports tree that has exactly what I want; RipperX is close.
> Any clues appreciated.
> I'm not subscribed to multimedia; please Cc: me if possible. Thanks,
> and best regards.

Hope this helps,

More information about the freebsd-multimedia mailing list