faad2 make fails

DA Forsyth d.forsyth at ru.ac.za
Tue Mar 23 07:53:30 UTC 2010


On a FreeBSD 7.2 system I get this failure
config.log is attached

portupgrade faad2
--->  Upgrading 'faad2-2.7_1,1' to 'faad2-2.7_2,1' (audio/faad)
--->  Building '/usr/ports/audio/faad'
===>  Cleaning for faad2-2.7_2,1
===>  WARNING: Vulnerability database out of date, checking anyway
===>  Extracting for faad2-2.7_2,1
=> MD5 Checksum OK for faad2-2.7.tar.bz2.
=> SHA256 Checksum OK for faad2-2.7.tar.bz2.
===>  Patching for faad2-2.7_2,1
===>   Converting DOS text files to UNIX text files
===>  Applying FreeBSD patches for faad2-2.7_2,1
===>   faad2-2.7_2,1 depends on executable: gmake - found
===>   faad2-2.7_2,1 depends on file: /usr/local/bin/automake-1.10 - 
found
===>   faad2-2.7_2,1 depends on file: /usr/local/bin/autoconf-2.62 - 
found
===>   faad2-2.7_2,1 depends on package: libtool>=2.2 - found
===>  Configuring for faad2-2.7_2,1
configure.in:14: warning: AC_CACHE_VAL(lt_prog_compiler_static_works, 
...): suspicious cache-id, must contain _cv_ to be cached
../../lib/autoconf/general.m4:1973: AC_CACHE_VAL is expanded from...
../../lib/autoconf/general.m4:1993: AC_CACHE_CHECK is expanded 
from...
/usr/local/share/aclocal/libtool15.m4:640: AC_LIBTOOL_LINKER_OPTION 
is expanded from...
/usr/local/share/aclocal/libtool15.m4:2551: _LT_AC_LANG_C_CONFIG is 
expanded from...
/usr/local/share/aclocal/libtool15.m4:2550: AC_LIBTOOL_LANG_C_CONFIG 
is expanded from...
/usr/local/share/aclocal/libtool15.m4:80: AC_LIBTOOL_SETUP is 
expanded from...
/usr/local/share/aclocal/libtool15.m4:60: _AC_PROG_LIBTOOL is 
expanded from...
/usr/local/share/aclocal/libtool15.m4:25: AC_PROG_LIBTOOL is expanded 
from...
configure.in:14: the top level
configure.in:14: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works, 
...): suspicious cache-id, must contain _cv_ to be cached
/usr/local/share/aclocal/libtool15.m4:595: AC_LIBTOOL_COMPILER_OPTION 
is expanded from...
/usr/local/share/aclocal/libtool15.m4:4666: 
AC_LIBTOOL_PROG_COMPILER_PIC is expanded from...
configure.in:14: warning: 
AC_CACHE_VAL(lt_prog_compiler_pic_works_CXX, ...): suspicious cache-
id, must contain _cv_ to be cached
/usr/local/share/aclocal/libtool15.m4:2663: _LT_AC_LANG_CXX_CONFIG is 
expanded from...
/usr/local/share/aclocal/libtool15.m4:2662: 
AC_LIBTOOL_LANG_CXX_CONFIG is expanded from...
/usr/local/share/aclocal/libtool15.m4:1701: _LT_AC_TAGCONFIG is 
expanded from...
configure.in:14: warning: 
AC_CACHE_VAL(lt_prog_compiler_pic_works_F77, ...): suspicious cache-
id, must contain _cv_ to be cached
/usr/local/share/aclocal/libtool15.m4:3756: _LT_AC_LANG_F77_CONFIG is 
expanded from...
/usr/local/share/aclocal/libtool15.m4:3755: 
AC_LIBTOOL_LANG_F77_CONFIG is expanded from...
configure.in:14: warning: 
AC_CACHE_VAL(lt_prog_compiler_pic_works_GCJ, ...): suspicious cache-
id, must contain _cv_ to be cached
/usr/local/share/aclocal/libtool15.m4:3862: _LT_AC_LANG_GCJ_CONFIG is 
expanded from...
/usr/local/share/aclocal/libtool15.m4:3861: 
AC_LIBTOOL_LANG_GCJ_CONFIG is expanded from...
configure.in:14: warning: AC_CACHE_VAL(lt_prog_compiler_static_works, 
...): suspicious cache-id, must contain _cv_ to be cached
../../lib/autoconf/general.m4:1973: AC_CACHE_VAL is expanded from...
../../lib/autoconf/general.m4:1993: AC_CACHE_CHECK is expanded 
from...
aclocal.m4:1547: AC_LIBTOOL_LINKER_OPTION is expanded from...
aclocal.m4:3458: _LT_AC_LANG_C_CONFIG is expanded from...
aclocal.m4:3457: AC_LIBTOOL_LANG_C_CONFIG is expanded from...
aclocal.m4:987: AC_LIBTOOL_SETUP is expanded from...
aclocal.m4:967: _AC_PROG_LIBTOOL is expanded from...
aclocal.m4:932: AC_PROG_LIBTOOL is expanded from...
configure.in:14: the top level
configure.in:14: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works, 
...): suspicious cache-id, must contain _cv_ to be cached
aclocal.m4:1502: AC_LIBTOOL_COMPILER_OPTION is expanded from...
aclocal.m4:5561: AC_LIBTOOL_PROG_COMPILER_PIC is expanded from...
configure.in:14: warning: 
AC_CACHE_VAL(lt_prog_compiler_pic_works_CXX, ...): suspicious cache-
id, must contain _cv_ to be cached
aclocal.m4:3566: _LT_AC_LANG_CXX_CONFIG is expanded from...
aclocal.m4:3565: AC_LIBTOOL_LANG_CXX_CONFIG is expanded from...
aclocal.m4:2608: _LT_AC_TAGCONFIG is expanded from...
configure.in:14: warning: 
AC_CACHE_VAL(lt_prog_compiler_pic_works_F77, ...): suspicious cache-
id, must contain _cv_ to be cached
aclocal.m4:4655: _LT_AC_LANG_F77_CONFIG is expanded from...
aclocal.m4:4654: AC_LIBTOOL_LANG_F77_CONFIG is expanded from...
configure.in:14: warning: 
AC_CACHE_VAL(lt_prog_compiler_pic_works_GCJ, ...): suspicious cache-
id, must contain _cv_ to be cached
aclocal.m4:4761: _LT_AC_LANG_GCJ_CONFIG is expanded from...
aclocal.m4:4760: AC_LIBTOOL_LANG_GCJ_CONFIG is expanded from...
configure.in:14: warning: AC_CACHE_VAL(lt_prog_compiler_static_works, 
...): suspicious cache-id, must contain _cv_ to be cached
../../lib/autoconf/general.m4:1973: AC_CACHE_VAL is expanded from...
../../lib/autoconf/general.m4:1993: AC_CACHE_CHECK is expanded 
from...
aclocal.m4:1547: AC_LIBTOOL_LINKER_OPTION is expanded from...
aclocal.m4:3458: _LT_AC_LANG_C_CONFIG is expanded from...
aclocal.m4:3457: AC_LIBTOOL_LANG_C_CONFIG is expanded from...
aclocal.m4:987: AC_LIBTOOL_SETUP is expanded from...
aclocal.m4:967: _AC_PROG_LIBTOOL is expanded from...
aclocal.m4:932: AC_PROG_LIBTOOL is expanded from...
configure.in:14: the top level
configure.in:14: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works, 
...): suspicious cache-id, must contain _cv_ to be cached
aclocal.m4:1502: AC_LIBTOOL_COMPILER_OPTION is expanded from...
aclocal.m4:5561: AC_LIBTOOL_PROG_COMPILER_PIC is expanded from...
configure.in:14: warning: 
AC_CACHE_VAL(lt_prog_compiler_pic_works_CXX, ...): suspicious cache-
id, must contain _cv_ to be cached
aclocal.m4:3566: _LT_AC_LANG_CXX_CONFIG is expanded from...
aclocal.m4:3565: AC_LIBTOOL_LANG_CXX_CONFIG is expanded from...
aclocal.m4:2608: _LT_AC_TAGCONFIG is expanded from...
configure.in:14: warning: 
AC_CACHE_VAL(lt_prog_compiler_pic_works_F77, ...): suspicious cache-
id, must contain _cv_ to be cached
aclocal.m4:4655: _LT_AC_LANG_F77_CONFIG is expanded from...
aclocal.m4:4654: AC_LIBTOOL_LANG_F77_CONFIG is expanded from...
configure.in:14: warning: 
AC_CACHE_VAL(lt_prog_compiler_pic_works_GCJ, ...): suspicious cache-
id, must contain _cv_ to be cached
aclocal.m4:4761: _LT_AC_LANG_GCJ_CONFIG is expanded from...
aclocal.m4:4760: AC_LIBTOOL_LANG_GCJ_CONFIG is expanded from...
configure.in:14: warning: AC_CACHE_VAL(lt_prog_compiler_static_works, 
...): suspicious cache-id, must contain _cv_ to be cached
../../lib/autoconf/general.m4:1973: AC_CACHE_VAL is expanded from...
../../lib/autoconf/general.m4:1993: AC_CACHE_CHECK is expanded 
from...
aclocal.m4:1547: AC_LIBTOOL_LINKER_OPTION is expanded from...
aclocal.m4:3458: _LT_AC_LANG_C_CONFIG is expanded from...
aclocal.m4:3457: AC_LIBTOOL_LANG_C_CONFIG is expanded from...
aclocal.m4:987: AC_LIBTOOL_SETUP is expanded from...
aclocal.m4:967: _AC_PROG_LIBTOOL is expanded from...
aclocal.m4:932: AC_PROG_LIBTOOL is expanded from...
configure.in:14: the top level
configure.in:14: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works, 
...): suspicious cache-id, must contain _cv_ to be cached
aclocal.m4:1502: AC_LIBTOOL_COMPILER_OPTION is expanded from...
aclocal.m4:5561: AC_LIBTOOL_PROG_COMPILER_PIC is expanded from...
configure.in:14: warning: 
AC_CACHE_VAL(lt_prog_compiler_pic_works_CXX, ...): suspicious cache-
id, must contain _cv_ to be cached
aclocal.m4:3566: _LT_AC_LANG_CXX_CONFIG is expanded from...
aclocal.m4:3565: AC_LIBTOOL_LANG_CXX_CONFIG is expanded from...
aclocal.m4:2608: _LT_AC_TAGCONFIG is expanded from...
configure.in:14: warning: 
AC_CACHE_VAL(lt_prog_compiler_pic_works_F77, ...): suspicious cache-
id, must contain _cv_ to be cached
aclocal.m4:4655: _LT_AC_LANG_F77_CONFIG is expanded from...
aclocal.m4:4654: AC_LIBTOOL_LANG_F77_CONFIG is expanded from...
configure.in:14: warning: 
AC_CACHE_VAL(lt_prog_compiler_pic_works_GCJ, ...): suspicious cache-
id, must contain _cv_ to be cached
aclocal.m4:4761: _LT_AC_LANG_GCJ_CONFIG is expanded from...
aclocal.m4:4760: AC_LIBTOOL_LANG_GCJ_CONFIG is expanded from...
checking for a BSD-compatible install... /usr/bin/install -c -o root 
-g wheel
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... ./install-sh -c -d
checking for gawk... no
checking for mawk... no
checking for nawk... nawk
checking whether gmake sets $(MAKE)... yes
./configure: 2553: Syntax error: word unexpected (expecting ")")
===>  Script "configure" failed unexpectedly.

Please report the problem to multimedia at FreeBSD.org [maintainer] and 
attach the "/usr/ports/audio/faad/work/faad2-2.7/config.log" 
including the output of the failure of your make command. Also, it 
might be a good idea to provide an overview of all packages installed 
on your system (e.g. an `ls /var/db/pkg`).  

*** Error code 1

Stop in /usr/ports/audio/faad.
** Command failed [exit code 1]: /usr/bin/script -qa 
/tmp/portupgrade20100323-74562-j0k2f0-0 env UPGRADE_TOOL=portupgrade 
UPGRADE_PORT=faad2-2.7_1,1 UPGRADE_PORT_VER=2.7_1,1 make
** Fix the problem and try again.
** Listing the failed packages (-:ignored / *:skipped / !:failed)
        ! audio/faad (faad2-2.7_1,1)    (unknown build error)

Thanks

--
       DA Fo rsyth            Network Supervisor
Principal Technical Officer -- Institute for Water Research
http://www.ru.ac.za/institutes/iwr/


-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.log
Type: application/octet-stream
Size: 5541 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-multimedia/attachments/20100323/73e52263/config.obj


More information about the freebsd-multimedia mailing list