webcamd/pwcview report

Milan Obuch freebsd-multimedia at
Thu Apr 29 06:51:38 UTC 2010


today I tried webcam support on my MSI Wind U100 netbook. I just did

cd /usr/ports/multimedia/webcamd
make install clean
cd /usr/ports/multimedia/pwcview
make install clean
kldload cuse4bsd
/usr/local/etc/rc.d/webcamd onestart

and it just worked. Big thanks to Hans Petter who made this possible. I was 
able to test with both internal webcamera and small external camera:

usbconfig -u 0 -a 2 dump_device_desc
ugen0.2: <Generic Digital camera Sunplus Technology Co., Ltd.> at usbus0, 
cfg=0 md=HOST spd=FULL (12Mbps) pwr=ON

  bLength = 0x0012
  bDescriptorType = 0x0001
  bcdUSB = 0x0110
  bDeviceClass = 0x00ff
  bDeviceSubClass = 0x00ff
  bDeviceProtocol = 0x0000
  bMaxPacketSize0 = 0x0008
  idVendor = 0x04fc
  idProduct = 0x0561
  bcdDevice = 0x0000
  iManufacturer = 0x0001  <Sunplus Technology Co., Ltd.>
  iProduct = 0x0002  <Generic Digital camera>
  iSerialNumber = 0x0000  <no string>
  bNumConfigurations = 0x0001

usbconfig -u 4 -a 2 dump_device_desc
ugen4.2: <USB 2.0 Camera Sonix Technology Co., Ltd.> at usbus4, cfg=0 md=HOST 
spd=HIGH (480Mbps) pwr=ON

  bLength = 0x0012
  bDescriptorType = 0x0001
  bcdUSB = 0x0200
  bDeviceClass = 0x00ef
  bDeviceSubClass = 0x0002
  bDeviceProtocol = 0x0001
  bMaxPacketSize0 = 0x0040
  idVendor = 0x0c45
  idProduct = 0x62c0
  bcdDevice = 0x0100
  iManufacturer = 0x0002  <Sonix Technology Co., Ltd.>
  iProduct = 0x0001  <USB 2.0 Camera>
  iSerialNumber = 0x0003  <SN0001>
  bNumConfigurations = 0x0001

Test was made with both 8.0-STABLE and 9.0-CURRENT.

There is one issue in my case: I tested it under console, and after 
pressing 'q' display remains dark. No output seen there any more, but I can 
blindly type 'pwciew' and image from webcamera is there again. Card used 
there is

vgapci0 at pci0:0:2:0:     class=0x030000 card=0x01101462 chip=0x27ae8086 
rev=0x03 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Mobile 945 Express Chipset Family'
    class      = display
    subclass   = VGA

Also, I would like to run pwcview or something similar remotely, maybe over 
ssh connection. No success now, just cleared screen. If someone has any 
advice, I am all ears.


More information about the freebsd-multimedia mailing list