Repeatable X lockups

William Bulley web at
Wed May 6 16:14:53 UTC 2009

According to Jimmie James <jimmiejaz at> on Sat, 05/02/09 at 15:46:
> When using the xv output driver for vlc or mplayer, X will lockup, crash 
> instantly, trashing the screen and forcing a reboot
> Image of screen corruption: 
> This just started manifesting in the past week or so.

I have experienced the same problem, but I didn't see any suggestions
or answers to your posting.  Have you had any success yet with this?
Have you tried any other output drivers?  This is something I plan to
try in the next few days.

My system is i386 with Intel 915 graphics on the motherboard.  Xorg 7.4
runs fine.  When I run mplayer from the command line, in an xterm under
open-motif, the X Windows session dies and I am tossed back to the vty.

When I similarly run vlc from the command line, the screen is locked in
an even worse state than your above URL.  I am forced to ssh(1) in from
another FreeBSD workstation to reboot.  Before the reboot, ps(1) reports
no processes running xorg or any of its child processes, it seems as if
my video hardware has been left in some ugly, locked-up, unusable state.

What is interesting to me is that the same flash file that causes vlc
and mplayer to crash runs just fine in ffplay(1) (part of ffmpeg port).
Yet at least vlc uses ffmpeg, while it doesn't look like mplayer does.

This is 7.2-PRERELEASE built on 24 Apr 2009 with the ports of mplayer
and vlc built on 2 May 2009 following a csup(1) of complete ports tree
on either 24 Apr or 25 Apr - so approximately the same timeframe as you.



William Bulley                     Email: web at

The information contained in this message may be CONFIDENTIAL
and is for the intended addressee only.  Any unauthorized use,
dissemination of the information, or copying of this message
is prohibited.  If you are not the intended addressee, please
notify the sender immediately, and delete this message.

More information about the freebsd-multimedia mailing list