ports/131647: audio/libsndfile: Problem to build libsndfile-1.0.18

Andrew Reilly andrew-freebsd at areilly.bpc-users.org
Sun Feb 22 17:03:30 PST 2009

For what it's worth, I just got this to build OK, with
a little manual tweaking.  There were two problems:
/usr/local/include/sndfile.h was being picked up before the
version in ../src, and the installed version didn't include a
symbol something like SF_EXTENSION_WAV.  So I moved those aside
and the local version was picked-up, and that worked.

The second problem was the linker couldn't find
-lgfortran or -gfortranbegin.  This was trickier, and
I don't really know why adding the appropriate pair of
directories to the Makefile didn't take.  Those libraries
are (on my system) in /usr/local/lib/gcc-4.3.4 and
I added those to the LDFLAGS symbol, but the linker command
line was still trying to use the 4.3.3 versions.  Not sure
why.  Maybe my libtool is out of date.  Anyway, I forced the
issue by symlinking all of the library files directly into
/usr/local/lib, and that seems to have worked.  Well, it all
built and installed neatly; I haven't tested it yet.



More information about the freebsd-multimedia mailing list