envy24ht driver pcm0:record:dsp0.r1: record interrupt timeout, channel dead

Douglas Medina doug.medz at gmail.com
Thu Aug 20 23:02:28 UTC 2009


I am trying to get a audiophile 192 to work on FreeBSD 7.2 release for
capturing audio.

The problem I have been having (I tried to record a small amount of wav
using wavrec) is

pcm0:record:dsp0.r1: record interrupt timeout, channel dead

the wavrec process hangs for about 4 seconds, and then the above message
appears in dmesg.  devinfo shows that the IRQ 18 is taken by pcm0 it is not
shared or anything.

Using sysctl i disabled vchans but this made no difference.  I also tried on
a seperate mainboard with a completely different chipset/vendor etc.  I had
exactly the same error.

Then I tried using Konstantin Dimitrov's patched envy24ht.c envh24ht.h and
they compile cleanly, and insert to running kernel without problem, but the
exact same issue persisted.

Since the computer in question has onboard audio after I exhausted
everything I could think of to try,  I enabled the onboard audio in the BIOS
and tried recording and that worked without problems.

I also tried a revolution 7.1 and had the exact same issue.  The audiophile
192 in question I have since tested in windows on the exact same hardware,
and it works.

I would be happy to try any suggestions, patches or whatever.  I also have a
1010lt at my disposal.

Douglas Medina

More information about the freebsd-multimedia mailing list