FreeBSD port for zoneminder 1.23.3

Boris Samorodov bsam at
Tue Oct 7 09:30:32 UTC 2008

Achilleas Mantzios <achill at> writes:
> Στις Tuesday 07 October 2008 11:07:48 ο/η Boris Samorodov έγραψε:
>> Achilleas Mantzios <achill at> writes:
>> > Στις Tuesday 07 October 2008 00:10:59 ο/η Boris Samorodov έγραψε:
>> >> Hi!
>> >> 
>> >
>> > Добро Утро!
>> Доброе! ;-)
>> >> Achilleas Mantzios <achill at> writes:
>> >> 
>> >> > In case some one is interested here is the announcement:
>> >> >
>> >> >
>> >> 
>> >> I've read the thread and tried to build packages.
>> >> 
>> >> First, I had to add a dependency upon gnutls. But I'n not sure
>> >> what kind of dependency it should be. There are build, run and
>> >> library dependencies at the port's Makefile.
>> Can you answer this question? I'd like to suggest a patch to your port
>> but can't do it without that information.
> If (it compiles without gnutls) {
> 	compile it and invoke the programms (run zoneminder);

I can't run the program since I haven't got a card so far.
But I want to commit your port to the FreeBSD port's tree
and hence try to compile it.

> 	if (missing lib dependancies prevents it from running) {
> 		add those deps as LIB_DEPENDS
> 	}
> 	if (other software (e.g. mysql) is needed to run but not exists)  {
> 		add those deps to RUN_DEPENDS
> 	}
> }
> else {
> 	add the required s/w as BUILD_DEPENDS
> }
> (well, thats my understanding, however i must say that i had gnutls all the way since day 1,
> and maybe thats why i didnt come across this problem)
> At which part does the whole build or run require gnutls?

At configure stage:
checking for pcre.h... yes
checking whether round is declared... yes
checking whether strsignal is declared... yes
test: unexpected operator
checking whether MD5 is declared... no
configure: error: zm requires gnutls/openssl.h - use ZM_SSL_LIB option to select openssl instead
===>  Script "configure" failed unexpectedly.
Please report the problem to achill at [maintainer] and
attach the
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. an `ls /var/db/pkg`).
*** Error code 1

Stop in /a/ports/multimedia/zoneminder.

>> >> Second, I've got errors which had been described at the forum.
>> >> As I understand from forum those arrors should disappear with
>> >> current ffmpeg port. But I see those errors for all amd64
>> >
>> > First off, i dont have neither 7.1 or 8.0 or amd64 handy.
>> The error is identical at all systems, so there is no need to have all
>> of them. BTW, 7-STABLE and 8-CURRENT -i386 suffers the same error:
>> Actually, one shouldn't have all systems at hand -- ports-mgmt/tinderbox
>> is a great tool.
> Aha i'll note that.
>> > Actually from what the posters on 
>> >
>> > say, i conclude that the problem arises with the current ffmpeg port and not vice versa.
>> > One user (vess) suggested that you rebuild ffmpeg with --enable-swscale,
>> > and remove files/patch_zm_mpeg.cpp.
>> > You can try it and post the results to forum thread in order for future
>> > users to have a complete view of all efforts/successes done.
>> Well, as I'd said, I've read this thread. Actually, many times. ;-)
>> But nothing helped me.
>> Current multimedia/ffmpeg port uses --enable-swscale by default (since
>> 10 Aug 2008) and doesn't have files/patch_zm_mpeg.cpp. That's why I
>> wrote "nothing helps".
> I think you should try to cd /usr/ports/multimedia/zoneminder and try to 
> traditionally "make install" without any fancy tools, then try to find out

Well, this fancy tool is used to emulate a pure OS. That's why it
found out a missing dependency upon security/gnutls. There is no
difference other than that. But I'll try to compile the port at my

> where the source-level incompatibility from previous ffmpeg is lying .

OK, then you say that I need to compile your port with old
mutimedia/ffmpeg version?

> In that case you should simply prepare your own patch for ffmpeg and maybe update the port
> against the new ffmpeg.
> I dont know if there is a way so as to programmatically have the previous patch for
> old ffmpeg and the new one for new.

We can create a port ffmpeg-old (or else) IF it is needed. Or convince
ffmpeg maintainer to create, say, an OPTION to the port. There are
some ways. But first of all we need to know where is the touble...

> Sorry i cant help more. Changing the source to make it compile and work is the only way.
>> >> FreeBSD versions:
>> >>,1.log
>> >>,1.log
>> >>,1.log
>> >> 
>> >> Packages were build by ports-mgmt/tinderbox.
>> >> What did I miss? Any help is appresiated. Thanks.

Boris Samorodov (bsam)
Research Engineer, Telephone & Internet SP
FreeBSD committer, The Power To Serve

More information about the freebsd-multimedia mailing list