oss's hdaudio.ko won't load

Ben Kaduk minimarmot at gmail.com
Sat Mar 1 20:04:43 UTC 2008

Hi Chuck,

On 2/29/08, Chuck Robey <chuckr at chuckr.org> wrote:
>  Hash: SHA1
>  Well, now the oss has stopped, so I gotta get interested here.  Here's the
>  facts:
>  I run FreeBSD-current, and the oss comes from the port, recently
>  reinstalled.  What used to happen on boot was, I would see a bold-print
>  near the very end of single-user, printing "hdaudio0 [ITHREAD]", whereupon
>  it would hang.  I tried removing the oss from rc.conf, and then running
>  /usr/local/sbin/soundon manually.  I get the same bold print, but the only
>  thing to  hang is the root session I launched it from, I could easily look
>  at things from different vtys, which I did.  I saw that soundon was trying
>  to load a "hdaudio.ko" that oss stashes in it's private module repository
>  at /usr/local/lib/oss/modules.  I tried to use kldstat -v to see if it was
>  in fact loaded, it told me no.  I tried to load it manually vi kldload, it
>  comes back that it's already there.  Something is screwy with the loading
>  of hdaudio.ko.

Do you have any sound-related entries in your kernel configuration?
I haven't had time to get hdaudio setup on my new machine yet, but
I'm pretty sure that the symbols in the native snd_hda driver would
conflict with OSS's hdaudio.ko .  I think I remember running into
``module already present'' when something was compiled
into the main kernel, before.

-Ben Kaduk

More information about the freebsd-multimedia mailing list