Questions about snd_emu10kx

Mark Kane mark at
Tue Jan 22 14:10:11 PST 2008

Hi everyone.

I've been using snd_emu10k1 for a long time with my Audigy 2 Platinum
and it has been working great. Recently I moved to FreeBSD 7 and was
experiencing problems recording (I believe the same or similar issues to
kern/119759), so I had to switch to snd_emu10kx to urgently get
something recorded. With emu10kx I have noticed a few things that I
have questions about:

1) The headphone jack on the front panel of the Audigy 2 Platinum is
not outputting sound like it did with emu10k1. I have tried with all
mixer levels up with no luck. Is this a misconfiguration, known
bug/limitation, or an unknown issue that I should file a PR for?

2) I no longer seem to be able to mute the line input from coming out
of the card while still recording from it. In emu10k1 I could set
"line" in the mixer to 0, but "rec" higher with the recording source
set to line and it would still record while not being outputted from
the card. With emu10kx, if I set "line" to 0 even with the source set to
line and "rec" at 100 no audio is recorded from the line. I have also
tried setting the recording source to "line1" and setting "line" to 0
but then it does not record either.

3) Last night I noticed that I was not able to play any audio with a
48kHz sample rate. I'm pretty sure it was working after switching from
emu10k1 to emu10kx but last night it suddenly stopped working. In XMMS
or Audacity a buzz/stuttering sound is outputted when playing a
48kHz file. In mplayer, playing a video with 48kHz audio causes it not
to play correctly (it will play a frame of video then stop playing). If
playing video in VLC with 48kHz audio it will play the video only with
no sound. If I try using jackd and ZynAddSubFX with a 48kHz sample rate
it also does not output any sound. There are no errors
in /var/log/messages or from the applications themselves so I'm not
sure what is causing this problem. I did update some ports but I'm not
sure if that's related to this, or what would cause all applications to
fail with anything 48kHz.

Below is some information about my setup. Any suggestions would be much

Thanks in advance,


FreeBSD 7.0-PRERELEASE amd64

[mixx941 at amd645200:~]% cat /dev/sndstat
FreeBSD Audio Driver (newpcm: 64bit 2007061600/amd64)
Installed devices:
pcm0: <EMU10Kx DSP front PCM interface> on emu10kx0 [MPSAFE]
(4p:1v/1r:2v channels duplex default) 
pcm1: <EMU10Kx DSP rear PCM interface> on emu10kx0 [MPSAFE]
(1p:1v/0r:0v channels) 
pcm2: <EMU10Kx interface> DSP center PCM interface> on emu10kx0
[MPSAFE] (1p:1v/0r:0v interface> channels)
pcm3: <EMU10Kx DSP subwoofer PCM interface> on emu10kx0 [MPSAFE]
(1p:1v/0r:0v channels)

emu10kx0 at pci0:1:0:0:	class=0x040100 card=0x10021102
chip=0x00041102 rev=0x04 hdr=0x00 vendor     = 'Creative Technology
LTD.' device     = 'Creative SB Audigy 2 ZS (WDM) Audigy Audio
Processor' class      = multimedia
    subclass   = audio

Mixer vol      is currently set to  65:65
Mixer pcm      is currently set to  72:72
Mixer speaker  is currently set to  75:75
Mixer line     is currently set to  80:80
Mixer mic      is currently set to   0:0
Mixer cd       is currently set to  75:75
Mixer rec      is currently set to 100:100
Mixer igain    is currently set to  95:95
Mixer ogain    is currently set to  50:50
Mixer line1    is currently set to  75:75
Mixer line2    is currently set to  75:75
Mixer line3    is currently set to  75:75
Mixer dig1     is currently set to   0:0
Mixer dig2     is currently set to   0:0
Mixer dig3     is currently set to   0:0
Mixer phin     is currently set to  50:50
Mixer phout    is currently set to  50:50
Mixer video    is currently set to  75:75
Recording source: line

Internet Radio:
Party107 (Trance/Electronic) -
Rock 101.9 The Edge (Rock) -

MIXXnet IRC Network - (Nick: MIXX941)

More information about the freebsd-multimedia mailing list