audio/jack: jackd fails to start

Christian Walther cptsalek at
Fri Jan 18 16:12:20 PST 2008


today I installed audio/jack as needed for audio/ardour.
The problem is that ardour2 fails to initialize jackd during startup. Trying

$ jackd -d oss

gives the same error message:

jackd 0.103.0
Copyright 2001-2005 Paul Davis and others.
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

JACK compiled with System V SHM support.
loading driver ..
OSS: failed to open device /dev/dsp: oss_driver.c at 527, errno=2
cannot start driver
zsh: segmentation fault  jackd -d oss

I tried the following steps to solve this issue:
- Rebuilt jack without CFLAGS defined for optimization
- Rebuilt kernel + world with sources from todays stable, uname says:
FreeBSD 6.3-STABLE FreeBSD 6.3-STABLE #0: Fri Jan 18
23:51:25 UTC 2008     zoot at fairy:/usr/obj/usr/src/sys/FAIRY  i386
- Rebuilt jack afterwards (without CFLAGS), too

So far nothing helped. I did a truss on "jackd -d oss" and I guess the
following line is the most interesting one:

= 0 (0x0)

Is this a known issue and/or does anybody know how to solve it?


More information about the freebsd-multimedia mailing list