oss's hdaudio.ko won't load

Chuck Robey chuckr at chuckr.org
Fri Feb 29 18:54:53 UTC 2008

Hash: SHA1

I have a Asus Striker Extreme mobo, it's got a MCP55 Nvidia setup, and this
includes a Analog Devices AD1981 HD audio chip.  I'd had it working via the
oss driver, so having other problems to keep me interested (like trying to
get the usb driver for my graphic tablet working) so I stopped trying to
get the sound + snd_hda to work, it's so incredibly under-documented, I
couldn't have gotten the snd_hda working anyhow.

Well, now the oss has stopped, so I gotta get interested here.  Here's the

I run FreeBSD-current, and the oss comes from the port, recently
reinstalled.  What used to happen on boot was, I would see a bold-print
near the very end of single-user, printing "hdaudio0 [ITHREAD]", whereupon
it would hang.  I tried removing the oss from rc.conf, and then running
/usr/local/sbin/soundon manually.  I get the same bold print, but the only
thing to  hang is the root session I launched it from, I could easily look
at things from different vtys, which I did.  I saw that soundon was trying
to load a "hdaudio.ko" that oss stashes in it's private module repository
at /usr/local/lib/oss/modules.  I tried to use kldstat -v to see if it was
in fact loaded, it told me no.  I tried to load it manually vi kldload, it
comes back that it's already there.  Something is screwy with the loading
of hdaudio.ko.

Any idea what it might be?
Version: GnuPG v2.0.4 (FreeBSD)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the freebsd-multimedia mailing list