getting sound to work, and also my nvidia 8600GTS

Chuck Robey chuckr at
Thu Feb 28 22:14:20 UTC 2008

Hash: SHA1

Rick Nekus wrote:
> Hi,
> I'm not sure about dev**, but the defacto standard of any nvidia card is that it just works(in xBSD, Linux,....);
> ie: nvidia-driver-100.14.19
> #cd /usr/ports/x11/nvidia-driver;make install clean
> add your below to /boot/loader.conf
> #xorgconfig
> afterwards edit /etc/X11/xorg.conf and just
> uncomment "glx"
> change "nv" -> "nvidia"
> thats it. has worked great for me from nvidia agp 6200's -> pcix 8800GT'S, ...and beyond.
>> Date: Wed, 27 Feb 2008 21:24:48 +0300> From: yuri.pankov at> To: chuckr at> CC: freebsd-multimedia at> Subject: Re: getting sound to work, and also my nvidia 8600GTS> > On Wed, Feb 27, 2008 at 12:37:23PM -0500, Chuck Robey wrote:> <snip>> > Maybe I should drop this at this point, but my nvidia.ko file, which is the> > driver for my 8600 GTS card, it never seems to get started. How do I know> > this? Because the /dev/nvidiactl file doesn't get made.> > nvidia_load="YES" in /boot/loader.conf ?> > > I am running devfs. Is this the right one for current? I'm not running> > devd, is that right. or maybe should I run both devd AND devfs? Or, anyone> > know which one is the right one to run? I need to get nvidiactl to be> > created, like it used to do 2 weeks ago.> > HTH,> Yuri> _______________________________________________> freebsd-multimedia at mailing list>> To unsubscribe, send any
 mail to "freebsd-multimedia-unsubscribe at"

Wanted to say thanks to you and Yuri for the pokes.  It's not the problem,
but you folks are sure right on attacking the siplest things first.  Begin
with the fact that kldstat does show the appearance of nvidia.ko, but when
I look at Xorg.0.log, it's telling me it can't find the nvidia kernel
module (it's language, not mine).  The fact that i can't see any
/dev/nvidiactl is just a convenient thing to add as a extra problem
pointer, because when it works right, I _do_ see that file show up.

I had already configured the xorg.conf, and that's the way I'm using X11
right now, by setting vesa back into it.  When I test, it says nvidia
(never even tried nv).  glx is in there also.

I don't understand your comment about "#xorgconfig" could you let me in on
what that is?  I thought that # was a comment introducer, not like what it
does in cpp.

Beyond that, I had begun life here (nvidia-life, that is) with the output
of NVIDIA-FreeBSD-x86-100.14.19.tar.gz, but when I looked at the nvidia
website, it seems that there have been actually two never tarballs, so i
tried also the NVIDIA-FreeBSD-x86-169.12.tar.gz.  Don't askl me about the
weird version numbering, I realize it's wacky, but I couldn't find any
better info on their site.  Anyhow, I tried the both of them, they seem to
give exactly the same reaction to me.

I am wondering about one possible area of problem,  It might seem to you
like the tail wagging the dog, but I want to focus more on the absence of
the /dev/nvidiactl file (which might possibly be the way that xorg detects
the driver, right?)  Anyhow, I am using devfs here, but there seem to be
two different tools on my freebsd-current box that do what seems to me to
be the eact same thing, meaning devd and devfs,  Any idea which one I
really ought to be running, or maybe both of them?  The nvidia notes don't
give any pointers about either, because apparently they didn't exist when
they wrote their usage notes.

Can you give me any help about the dev stuff?
Version: GnuPG v2.0.4 (FreeBSD)
Comment: Using GnuPG with Mozilla -


More information about the freebsd-multimedia mailing list