getting sound to work, and also my nvidia 8600GTS

Chuck Robey chuckr at
Wed Feb 27 18:10:13 UTC 2008

Hash: SHA1

I juat had a bad time wtih a balky raid array.  It's back now, but I can't
seem to get my Nvidia-based video driver, or audio to wrk

I'm runnning FreeBSD-current.  I've got a 8600-GTS Nvidia care, which ran
using the old 100.14.19 version just fine.  I first ran it from my own
debugged bersion, but soon the port caught up, and i moved to using the
port.  Well, about 2 weeks ago, I began seeing this behavior:  During boot,
I would get (at the very end of probing, just before rc.conf completed) a
boldface print to the console of "hdaudio0:[ITHREAD]", whereupon it would
seize up.  Since rc.conf hadn't finished, I couldn't bring up a vterm to
kill it, nor could I log in via ssh.  It wouod just hang.  I tried waiting
as long as an hour, but finally needed to reboot to fix this.

I figured it was a problem with my raid, because I had one drive giving me
lots of errors, and figured I had a missing block, something like that, but
after replacing that drive and fixing things back up, the behaviour
remains.  I tried not loading any drivers, and doing it instead after my
machine went multiuser, and found then it was the oss(4.0) driver that was
doing it to me.  If I run "soundon" manually, or the oss rc.d script
manually, I can kill the process with kill and things work ok, but the
sound never completes, and I never see any of the /dev/oss items, nor do I
see any of the dsp* files in /dev/.  I found, by looking at the osscore, it
wants the hdaudio.ko to be running, and according to kldstat, it's NOT
there, but if I try to load it via kldload, it tells me it's already
running.  Like I said, no /dev sound-type files get created.

I tried catting /dev/sndstat, and it tells me that oss4.0 is runnig, and it
knows about the hdaudio,  I just can't get anything created in /dev, so no
output from things like mpg123, none at all.

I have tried runnning (instead of oss) soound.ko and snd_hda.ko, but no
sound files get created in dev still, except, catting /dev/sndstat tells me
that pcm sound is working fine.

Any idea what I'm going wrong?

Maybe I should drop this at this point, but my nvidia.ko file, which is the
driver for my 8600 GTS card, it never seems to get started.  How do I know
this?  Because the /dev/nvidiactl file doesn't get made.

I am running devfs.  Is this the right one for current?  I'm not running
devd, is that right. or maybe should I run both devd AND devfs?  Or, anyone
know which one is the right one to run?  I need to get nvidiactl to be
created, like it used to do 2 weeks ago.
Version: GnuPG v2.0.4 (FreeBSD)
Comment: Using GnuPG with Mozilla -


More information about the freebsd-multimedia mailing list