kern/119759: [emu10k1] Can not record anything with emu10k1 on 7.0-PRERELEASE (Invalid argument) (regression)

Mark Kane mark at
Tue Feb 19 14:00:07 PST 2008

The following reply was made to PR kern/119759; it has been noted by GNATS.

From: Mark Kane <mark at>
To: Yuri <yuri at>, bug-followup at
Subject: Re: kern/119759: [emu10k1] Can not record anything with emu10k1 on
 7.0-PRERELEASE (Invalid argument) (regression)
Date: Tue, 19 Feb 2008 15:55:58 -0600

 On Tue, Feb 19, 2008, at 20:20:03 GMT, Yuri wrote:
 >  Now I tried again and it doesn't work again for me.
 >  Kernel: 7.0-PRERELEASE FreeBSD 7.0-PRERELEASE #4: Tue Feb 19
 > 08:18:11 PST 2008
 >  Seems the problem is intermittent or dependent on the version of 7.0.
 >  Relevant dmesg messages:
 >  pcm0: <TriTech TR28602 AC97 Codec>
 >  pcm0: [ITHREAD]
 >  at the time of failure:
 >  pcm0:record:dsp0.r1: record interrupt timeout, channel dead
 >  Sound recording is a major function and emu10k1 is probably a very
 > (if not most) common card.
 >  Is there any more debug messaging that could be turned on for this
 > driver? 
 I was just writing another reply to the PR with some additional
 information (mainly the dmesg messages and a workaround) but I will
 answer in reply to you here instead.
 Yesterday I came across kern/118546 and tried the suggestion of setting
 "dev.pcm.0.rec.vchans" to 0 which appears to have fixed the recording
 problem for me here on emu10k1. When set to 1 (the default) it does not
 record properly.
 I tried to adapt the patch from snd_ich in kern/118546 and in the
 commit that fixed the problem for that driver to emu10k1 but I am not
 very experienced in C yet so I did not have much luck.
 So for now, "sysctl dev.pcm.0.rec.vchans=0" allows recording to work
 again for me on an Audigy 2 Platinum with emu10k1 but a proper fix
 would be great too.

More information about the freebsd-multimedia mailing list