Skype-1.4 on 6.2 (and 7.0-BETA1)

Stefan Lambrev stefan.lambrev at moneybookers.com
Wed Oct 31 15:17:06 PDT 2007


Hi,

Andriy Gapon wrote:
> on 31/10/2007 12:36 Stefan Lambrev said the following:
>   
>> Hi Jan,
>>
>> Jan Henrik Sylvester wrote:
>>     
>>> Before, I had skype-1.2.0.18_4 on 6.2, which worked.
>>>
>>> Today, I portupgraded to skype-1.4.0.118.
>>>
>>> Now I only get: "Call Failed. Problem with Audio Playback".
>>>
>>> I killed artsd and increased hw.snd.maxautovchans and autovchans, but 
>>> nothing helped.
>>>
>>> Is the new version of Skype supposed to work on 6.2-RELEASE?
>>>
>>> For comparison, I rebooted into my test install of 7.0-BETA1 and 
>>> installed skype-1.4.0.118 there. Starting skype gave me:
>>>
>>> skype: error while loading shared libraries: /usr/lib/librt.so.1: ELF 
>>> file OS ABI invalid
>>>
>>> I solved that problem with a solution from emulation (about matlab):
>>>
>>> compat.linux.osrelease: 2.4.2 -> 2.4.20
>>>
>>> Is this expected? (I guess this question should go on emulation.)
>>>
>>> Anyhow, sound works on 7.0-BETA1.
>>>       
>> 20071030:
>>   AFFECTS: users of net/skype
>>   AUTHOR: beech at FreeBSD.org
>>
>>   The skype port has been upgraded to version 1.4.0.118. This requires a 
>> sysctl
>>   change to run. After upgrading, please do: "sysctl 
>> compat.linux.osrelease=2.6"
>>   from a terminal. Also add: "compat.linux.osrelease=2.6" to your
>>   /etc/sysctl.conf  to make this change at boot time. Also, 
>> net/skype-devel has
>>   been removed from the ports tree. All skype users are encouraged to 
>> update to
>>   the latest version.
>>
>> I personally jumped for linux_base-f7 and linuxolator 2.6, I have 
>> installed and linux_dri
>> and new skype seems to work perfect.
>>     
>
> BTW, is linux_base-f7 a requirement too ?
> Because on FreeBSD 6.2 fc4 is the default now and skype 1.4.X (from the
> port, of course) doesn't work for me, either with the default or with
> 2.6 value of compat.linux.osrelease. With 2.4.2 I get the same problem
> as Jan: "Call Failed. Problem with Audio Playback" for any attempt to call.
> With 2.6 skype simply didn't start with a message like "Can not setup
> LDT for thread something...".
>
> BTW, there is a different question that I have and maybe another part to
> my situation. My system is actually FreeBSD 6.2-RELEASE-p6 amd64,
> emphasis on amd64. So now you see what can add to my skype problems.
> And here's the question: our linuxolator emulates i386 Linux even on
> amd64, is there any reason that skype port has only i386 in the allowed
> archs ? The same question goes for any ports it depends on and that have
> the same restriction (if any). WITH_NVIDIA_GL is of course not
> applicable to amd64, bit otherwise, in my understanding, everything
> should. Am I missing something important ?
>   
Yes amd64 can cause problems, because you can't use WITH_NVIDIA_GL, 
which force you to use linux_dri which is also marked i386 only.
I'm not sure about new skype and freebsd on amd64.
What you can try is to change the Makefile of linux_dri (and skype) and 
to add amd64 to allowed archs.
Also if you do not run something mission critical you can go for f7 and 
experiment for yourself.
Last time when I checked linux-browsers and skype worked without 
problems on amd64, fc6, compat.linux.osrelease=2.6.16
So what stops you to experiment with latest things? :)

If you didn't get skype working on amd64 you can report this to the 
maintainer, and ask him to make a legacy port skype12 or something like 
this.

-- 

Best Wishes,
Stefan Lambrev
ICQ# 24134177



More information about the freebsd-multimedia mailing list