HDAC - no sound

Emmanuel Mie manumie at yahoo.fr
Sat Mar 24 13:40:53 UTC 2007


I've just landed on FreeBSD planet, so things are still a bit confused, but I'm trying.

I have a Dell Inspiron 640m (Core2Duo T5500) with Intel 82801G ICH7 integrated sound device.

I get no particular error or warning (see various outputs below), but I have no sound at all (either in KDE or in console # cat anyfile > /dev/dsp), I just can't figure it out.

I've been trying to get sound working, with the hdac drivers from Mr Ariff's page. I "made" hdac.ko, it didn't work. I patched it with both current.diff and snd_RELENG_6_20070312_150_lowlatency.diff.gz  (I've got to be honest : I didn't really know what I was doing)
There were errors : hunks failed, and it seems it didn't find hdac.c to patch - I had not redirected the output, so it's lost, unless there's some kind of log ?

I tried various setups and entries in /boot/loader.conf - nothing worked, so I removed all sound related entries, rebooted, and simply 
# kldstat hdac

Here are the outputs :

# uname -a
FreeBSD  6.2-RELEASE FreeBSD 6.2-RELEASE #0: Tue Mar 13 15:24:47 CET 2007     root@:/usr/obj/usr/src/sys/GENERIC  i386

# pciconf -lv | grep -B 4 multimedia
    class    = display
pcm0 at pci0:27:0: class=0x040300 card=0x01d81028 chip=0x27d88086 rev=0x01 hdr=0x00
    vendor   = 'Intel Corporation'
    device   = '82801G (ICH7 Family) High Definition Audio'
    class    = multimedia

# dmesg | grep ^pcm
pcm0: <Intel 82801G High Definition Audio Controller> mem 0xefebc000-0xefebffff irq 21 at device 27.0 on pci0
pcm0: Output Streams: 4, Input Streams: 4, Bidirectional Streams: 0
pcm0: CORB Size: 256, RIRB Size: 256
pcm0: Cap 1d0541 sf 0 st 0
pcm0: Set 0:3 10
pcm0: Cap 140311 sf e0160 st 5
pcm0: Set 0:4 20

# sysctl hw.snd.verbose='2' ; cat /dev/sndstat
FreeBSD Audio Driver (newpcm)
Installed devices:
pcm0: <Intel 82801G High Definition Audio Controller> w00t (1p/1r/0v channels duplex default)
 [pcm0:play:0:dsp0.0]: spd 0, fmt 0x00000000/0x00000008, flags 0x00000000, 0x00000000
 interrupts 0, underruns 0, ready 0 [b:4096/2048/2|bs:0/0/0]
 {userland} -> feeder_root(0x00000000) -> {hardware}
 [pcm0:record:0:dsp0.1]: spd 0, fmt 0x00000000/0x00000008, flags 0x00000000, 0x00000000
 interrupts 0, overruns 0, hfree 4096, sfree 0 [b:4096/2048/2|bs:0/0/0]
 {hardware} -> feeder_root(0x00000000) -> {userland}

# sysctl hw.snd
hw.snd.report_soft_formats: 1
hw.snd.targetirqrate: 32
hw.snd.verbose: 2
hw.snd.maxautovchans: 0
hw.snd.unit: 0
hw.snd.pcm0.buffersize: 0
hw.snd.pcm0.vchans: 0

# /usr/sbin/mixer
Mixer vol      is currently set to  75:75
Mixer rec      is currently set to   0:0
Recording source: 

I also tried setting vchans to 4 but no use. As I said, I'm new to FreeBSD, so I may very well misunderstand the way the system works.
And I'd really like to get this sound to work, as I'm supposed to use this computer to go and sell music around...

E. Mie

More information about the freebsd-multimedia mailing list