Xorg + CURRENT == computer reboot ... ?

Claus Guttesen kometen at gmail.com
Mon Jun 18 07:20:39 UTC 2007


> Okay, this is getting most frustrating ... and I think I've exhausted
> everything I can try, and I'm getting no where ...
>
> First ... I'm running Xorg 7.2 on a -CURRENT desktop ... I have an nvidia 4200
> video card in this machine, and am running the nvidia 9600 series driver from
> ports ...
>
> Before anyone points me to /usr/ports/UPDATING ... on this machine, I just did
> a pkg_delete -f * in /var/db/pkg to wipe everything, rm -rf /usr/local and just
> built everything fresh ... gave me a chance to clean out old ports I wasn't
> using anyway ...
>
> Everything is fine until I hit Ctl-C, at which point ... the computer just
> crashed/rebooted ...
>
> The only thing that *I* can see in Xorg.0.log is:
>
> _XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
> _XSERVTransOpen: transport open failed for inet6/purpleelephants.hub.org:0
> _XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6
>
> Not sure if that would cause it?  But I can't seem to find anything through
> Google as to "how to get rid of it" ... beyond that, everything seems clean to
> me, but I've included / attached the log file ...

My current would also reboot when doing xorgcfg (after I did a clean
install of current and ports). No entries in the logfiles did indicate
what the reason was.

I ended up copying an old xorg.conf and modified the file to
accomodate xorg's new /usr/local location. After that X started fine.

-- 
regards
Claus

When lenity and cruelty play for a kingdom,
the gentlest gamester is the soonest winner.

Shakespeare


More information about the freebsd-multimedia mailing list