pvr-350 not working - how to debug?

usleepless at gmail.com usleepless at gmail.com
Sat Apr 7 19:35:42 UTC 2007


Torfinn,

On 4/7/07, Torfinn Ingolfsen <torfinn.ingolfsen at broadpark.no> wrote:
> Hello,
>
> I have a pvr-350 in a desktop machine, and today i decided to upgrade
> the machine to the latest stable:
> tingo at kg-quiet$ uname -a
> FreeBSD kg-quiet.kg4.no 6.2-STABLE FreeBSD 6.2-STABLE #17: Sat Apr  7
> 18:45:15 CEST 2007     root at kg-quiet.kg4.no:/usr/obj/usr/src/sys/QUIET
> amd64
>
> and try out the new driver from usleep:
> http://usleepless.110mb.com/pvrxxx_port-01042007.tgz
>
> After getting the patch file for iicbb off this list, I made a new
> kernel, rebooted and installed the driver.
> The card is detected fine:
> Apr  7 18:58:18 kg-quiet kernel: cxm0: <Conexant iTVC15 MPEG Coder> mem
> 0xf8000000-0xfbffffff irq 20 at d
> evice 0.0 on pci2
> Apr  7 18:58:18 kg-quiet kernel: cxm_iic0: <Conexant iTVC15 / iTVC16 I2C
> controller> on cxm0
> Apr  7 18:58:18 kg-quiet kernel: iicbb0: <I2C bit-banging driver> on
> cxm_iic0
> Apr  7 18:58:18 kg-quiet kernel: iicbus0: <Philips I2C bus> on iicbb0
> master-only
> Apr  7 18:58:18 kg-quiet kernel: cxm0: Philips FM1216ME MK3 tuner
> Apr  7 18:58:18 kg-quiet kernel: cxm0: SAA7115 rev 1 video decoder
> Apr  7 18:58:18 kg-quiet kernel: cxm0: MSP4418G-B3 audio decoder
> Apr  7 18:58:18 kg-quiet kernel: cxm0: IR Remote
> Apr  7 18:58:18 kg-quiet kernel: cxm0: [FAST]
> Apr  7 18:58:18 kg-quiet kernel: cxm0: encoder firmware version 0x2060039
> Apr  7 18:58:18 kg-quiet kernel: cxm0: decoder firmware version 0x2020023
>
> However, when I try to use setchannel to set a frequency, like this:
>  pvr250-setchannel -m 4 196.25
> I get these errors in /var/log/messages:
> Apr  7 19:01:28 kg-quiet kernel: cxm0: video decoder failed to lock
> Apr  7 19:01:29 kg-quiet kernel: cxm0: audio decoder failed to lock
> Apr  7 19:03:22 kg-quiet kernel: cxm0: video decoder isn't locked
> Apr  7 19:03:22 kg-quiet kernel: Could not detect FPS
> Apr  7 19:03:22 kg-quiet kernel: could not config dec
> Apr  7 19:03:22 kg-quiet kernel: could not start encoder
> Apr  7 19:04:36 kg-quiet kernel: cxm0: video decoder isn't locked
> Apr  7 19:04:36 kg-quiet kernel: Could not detect FPS
> Apr  7 19:04:36 kg-quiet kernel: could not config dec
> Apr  7 19:04:36 kg-quiet kernel: could not start encoder
> Apr  7 19:10:07 kg-quiet kernel: cxm0: video decoder isn't locked
>
> For every frequency I try.
> I changed the cable, just to be on the safe side. No luck.
> I then decided to try the pvr250 port. It installs, the card is detected:
> Apr  7 19:31:21 kg-quiet kernel: cxm0: <Conexant iTVC15 MPEG Coder> mem
> 0xf8000000-0xfbffffff irq 20 at d
> evice 0.0 on pci2
> Apr  7 19:31:21 kg-quiet kernel: cxm_iic0: <Conexant iTVC15 / iTVC16 I2C
> controller> on cxm0
> Apr  7 19:31:21 kg-quiet kernel: iicbb0: <I2C bit-banging driver> on
> cxm_iic0
> Apr  7 19:31:21 kg-quiet kernel: iicbus0: <Philips I2C bus> on iicbb0
> master-only
> Apr  7 19:31:21 kg-quiet kernel: cxm0: Philips FM1216ME MK3 tuner
> Apr  7 19:31:21 kg-quiet kernel: cxm0: SAA7115 rev 1 video decoder
> Apr  7 19:31:21 kg-quiet kernel: cxm0: MSP4418G-B3 audio decoder
> Apr  7 19:31:21 kg-quiet kernel: cxm0: IR Remote
> Apr  7 19:31:21 kg-quiet kernel: cxm0: [GIANT-LOCKED]
> Apr  7 19:31:21 kg-quiet kernel: cxm0: encoder firmware version 0x2050032
> Apr  7 19:31:21 kg-quiet kernel: cxm0: decoder firmware version 0x2020023
>
> But I still get the same problem when I try to set a channel using
> pvr250-setchannel:
> Apr  7 19:31:48 kg-quiet kernel: cxm0: video decoder failed to lock
> Apr  7 19:32:07 kg-quiet kernel: cxm0: video decoder isn't locked
> Apr  7 19:32:16 kg-quiet kernel: cxm0: video decoder failed to lock
> Apr  7 19:32:32 kg-quiet last message repeated 2 times
> Apr  7 19:32:37 kg-quiet kernel: cxm0: video decoder isn't locked
> Apr  7 19:33:07 kg-quiet kernel: cxm0: video decoder failed to lock
> Apr  7 19:33:10 kg-quiet kernel: cxm0: video decoder isn't locked
> Apr  7 19:34:02 kg-quiet kernel: cxm0: video decoder failed to lock
> Apr  7 19:34:02 kg-quiet kernel: cxm0: audio decoder failed to lock
>
>
> Luckily, my main mythbackend (which have the pvr-500) is still working.
> Any hints on what I can do more to find the problem?

and this worked previously with the pvr250-port? strange?

anyhow: please test:
  http://usleepless.110mb.com/pvrxxx_port-07042007.tgz

i got tired of the "not supported tuner" requests and problems. i have
integrated the linux tuner-module and eeprom-module. so if i am not
mistaken, now all tuners ( that linux supports ) are supported.

let me know.

regards,

usleep


More information about the freebsd-multimedia mailing list