Call for testing: emu10kx driver for Creative sound cards

Warner Losh imp at
Tue May 23 20:56:49 UTC 2006

> giving.  I'd really like to see namespaces and name prefixes defined
> that have stable/unstable meaning.  I dropped this due to the very
> vocal opposition at the time.

Sounds like a good thing to me.  If we document this (and the bit that
I sent in my other email) in sysctl(8), or somewhere more appropriate,
then I think we can do this.  I propose that we put a single _ in
front of those sysctls that the author knows will go away and that no
code should be written to use them.  this would give the unstable
namespace that you want and would be consistant with what _foo()
functions are for.  Not sure if that means everything else is
permanant, however.  I'm hoping this doesn't result in a bikeshed of


More information about the freebsd-multimedia mailing list