Fwd: 64-bit bug in faac?

Kevin Downey redchin at gmail.com
Thu Jun 8 00:43:19 UTC 2006

---------- Forwarded message ----------
From: Kevin Downey <redchin at gmail.com>
Date: Jun 6, 2006 9:00 PM
Subject: Re: 64-bit bug in faac?
To: David Myers <myers at aedifice.net>

On 6/5/06, Kevin Downey <redchin at gmail.com> wrote:
> On 6/4/06, David Myers <myers at aedifice.net> wrote:
> ...
> >    FAAD: Failed to decode frame: Invalid number of channels
> ...
> > Anybody else seen this?  Any workarounds?
> I get the same thing on my amd64 machine. I am unaware of any fix. The
> cvs tree on sourceforge (for faac) has not been updated since Feb.
> '05, but then the version the port downloads has "2003-11-24" as the
> last entry in the ChangeLog.  I compiled the version from cvs rebuilt
> everything that depended on faac. I stopped seeing that error message,
> but I still get no sound. Infact mplayer now claims there is no sound
> on the mp4 files. I use ffmpeg with pretty much the same options to
> create the mp4 files.
> --
> luctor et emergo
Spoke too soon. On my second try compiling from cvs and then
portupgrade -Rrf faac -x faac I can use ffmpeg to make an mp4 with
mpeg4 video and aac sound that mplayer will play. I tried to make some
kind of port to build it, but I failed.

cvs -z3 -d:pserver:anonymous at faac.cvs.sourceforge.net:/cvsroot/faac co faac

to check out the source
--end of forwarded message--

http://thelastcitadel.com/lab/faac-cvs-port.tar.bz2 here is a "port"
that will grap faac from cvs, compile and install it. I am not sure if
pkg_delete will remove it because I did not make a pkg-plist. You
could just copy it from audio/faac/pkg-plist. It installs as
"faac-cvs" and is not setup to conflict with audio/faac even though it
certainly overwrites files from that port.
luctor et emergo

More information about the freebsd-multimedia mailing list