Vchan/Sound/patch hard locks...

Mike S. perlfu at gmail.com
Wed Sep 14 15:32:29 PDT 2005


    I've been having hard locks that are seeming related to vchans.  I can't manage to verify this with the logs, but judging by the fact that the locks only occur when two sounds are played together, and only some of the time at that.  I'm going to guess that's the issue.  Either way, I've been trying to use the patch found at, http://staff.mybsd.org.my/skywizard/FreeBSD/sound/incoming/, it's helped some, but hasn't entirely fixed the problem.  When I tried to upgrade the patch to the newest version, I got this error..

/usr/src/sys/modules/sound/sound/../../../dev/sound/pcm/ac97.c: In function `ac97_fix_volume':
/usr/src/sys/modules/sound/sound/../../../dev/sound/pcm/ac97.c:571: error: `SD_F_SOFTVOL' undeclared (first use in this function)
/usr/src/sys/modules/sound/sound/../../../dev/sound/pcm/ac97.c:571: error: (Each undeclared identifier is reported only once
/usr/src/sys/modules/sound/sound/../../../dev/sound/pcm/ac97.c:571: error: for each function it appears in.)
/usr/src/sys/modules/sound/sound/../../../dev/sound/pcm/ac97.c: At top level:
/usr/src/sys/modules/sound/sound/../../../dev/sound/pcm/ac97.c:576: error: redefinition of 'ac97_fix_volume'
/usr/src/sys/modules/sound/sound/../../../dev/sound/pcm/ac97.c:544: error: previous definition of 'ac97_fix_volume' was here
/usr/src/sys/modules/sound/sound/../../../dev/sound/pcm/ac97.c: In function `ac97_fix_volume':
/usr/src/sys/modules/sound/sound/../../../dev/sound/pcm/ac97.c:603: error: `SD_F_SOFTVOL' undeclared (first use in this function)
/usr/src/sys/modules/sound/sound/../../../dev/sound/pcm/ac97.c: In function `ac97_initmixer':
/usr/src/sys/modules/sound/sound/../../../dev/sound/pcm/ac97.c:631: warning: unused variable `bit'
/usr/src/sys/modules/sound/sound/../../../dev/sound/pcm/ac97.c:633: warning: unused variable `reg'
/usr/src/sys/modules/sound/sound/../../../dev/sound/pcm/ac97.c: At top level:
/usr/src/sys/modules/sound/sound/../../../dev/sound/pcm/ac97.c:544: warning: 'ac97_fix_volume' defined but not used
*** Error code 1

Stop in /usr/src/sys/modules/sound/sound.
*** Error code 1

Stop in /usr/src/sys/modules/sound.

    Also, my sound card is a VIA 8233.  Any insight, or suggestions regarding how to fix the locks, and or get the patch working would be greatly appreciated.  Thanks in advance.


More information about the freebsd-multimedia mailing list