5.2.1+5.3 sound worsening: now no devices at all!

Peter Much pmc at citylink.dinoex.sub.org
Mon Mar 28 12:12:48 PST 2005

Hi all,

beforehand: my soundcard worked just fine with Release 4.4.

When upgrading to 5.2.1, there was a problem with aviplay.
Other playback operations worked ok, but with aviplay the
sound was extremly distorted, and the status of the sound
system showed LOTS of buffer underruns. This was not related
to cpu load, because it was nearly as bad when the video 
output from aviplay was switched off. But then, without 
video, the sound was ok as long as one would _move_ the
mouse over the aviplay window.
Obviousely an event handling problem. 

So I decided to upgrade everything to 5.3 before starting
further investigations.

But now the sound does not work at all. I load sound.ko,
and it gives me /dev/sndstat.

Then I load snd_sbc.ko, and I see it recognizing the card
(device.hints are present) the same way as ever:
  sbc1: <ESS ES1869> at port 0x330-0x331,0x388-0x38b,0x220-0x22f
	irq 5 drq 0,1 on isa0
  sbc1: [GIANT-LOCKED]
but there are no devicenodes created in /dev, and /dev/sndstat 
shows no devices installed.
In the ps output, I see interrupt 5 correctly assigned to

I tried to compile both drivers into the kernel, same result.

If loaded with kldload, I can unload the snd_sbc.ko, but I
cannot unload sound.ko (Device busy) after it has been loaded.
Why is that thing busy when it doesnt work?? Should this be
that way?

I found no errors reported anywhere, and no Debug switches that
I could turn on. How is this ought to be debugged?


More information about the freebsd-multimedia mailing list