mplayer video output driver not working

Michael Nottebrock michaelnottebrock at
Thu Nov 25 22:02:00 PST 2004

On Friday, 26. November 2004 05:25, Kevin Smith wrote:
> I'm trying to get DVD playback working using mplayer (MPlayer
> 1.0pre5-3.4.2) on my system (P4 - BSD 5.3 with Nvidia FX5200).
> I have xine playing back DVD's just fine, but I would like to use
> mplayer as well.
> I built it from the ports tree (default options) and when I run mplayer
> using the following command, I get the following text back.


> Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
> ==========================================================================
> Audio: no sound
> Starting playback...
> VDec: vo config request - 720 x 480 (preferred csp: Planar YV12)
> VDec: using Planar YV12 as output csp (no 0)
> Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
> VO: [xv] 720x480 => 720x540 Planar YV12
> V:   0.0    1   0%  0%  0.0% 0 0 0%
> Exiting... (End of file)

The output doesn't suggest there's a problem with the video output driver. 

[mpegpes] is a special passthrough decoder driver for use with hardware mpeg2 
decoders. It comes first in the order of drivers to be tried for MPEG video, 
but will fail if no such hardware is present. The second decoder driver 
[mpeg12] is the one that's actually used, and it initializes just fine. 
However, the title you're trying to play seems to be just very very short 
(mplayer doesn't currently support DVD navigation menus, it just plays the 
available titles in ascending order, which is not necessarily the correct 

Try playing a different title (for example dvd://2).

   ,_,   | Michael Nottebrock               | lofi at
 (/^ ^\) | FreeBSD - The Power to Serve     |
   \u/   | K Desktop Environment on FreeBSD |

More information about the freebsd-multimedia mailing list