More on sound issues with 5.2.1-RELEASE on Dell I8000

Sean Welch Sean_Welch at
Mon Apr 26 18:16:50 PDT 2004

I apologize in advance for cross-posting; the nature of this issue
appears to be relevant to both lists.

I had posted earlier to the multimedia list about this problem.  In
short, I have discovered that with my batteries installed playing
any sounds through pcm (with the exception of audio cds) is plagued
by blurs or blips lasting fractions of a second.  Without batteries
installed this does not occur, and the symptoms are unrelated to AC
line status.  The problem isn't there under either 5.2-RELEASE or

I've been playing around a bit with FreeSBIE (nice!) and a lark
popped it into my Dell only to find that the sound issue wasn't

Earlier I had already tried all sorts of mods to the sound code and
also reverted to a GENERIC kernel but was unable to make the problem
go away.  This time I left everthing as I already had it (stock
sound code and custom kernel) and tried to play my test mp3 from the
command line using amp outside of X (gdm running, but logged in under
a vt) and there were no problems.  Then I started X on :1 (gdm had
:0) running just twm and neither amp nor xmms had a problem.  I added
gkrellm and still no problem.  I started up esd and still had no issues.

At this point, convinced it was something running under my gnome
session, I logged from gdm and immediately saw the sound problem
again.  Taking a stab in the dark I shut down the battery status
applet and the problem disappeared!

Curious, I tried switching to the apm component in gkrellm for
battery status and the problem returned.  I found the same issue
with xbattbar as well.  Evidently the issue is with the apm
emulation used to give battery status when using acpi; it looks as
though any program that polls this code causes the sound

A couple of wrinkles -- the blurs/blips return when the batteries
are all topped up and the AC line is connected.  I can trigger a
blur/blip by running the apm command, though it doesn't happen
absolutely every time I run it.  Specifically, it doesn't happen
every time when I run apm with short intervals between iterations.
Is there some sort of cache involved with this?

So what's the next step?


More information about the freebsd-multimedia mailing list