ADI AD1985 (ASUS P4P800) and no sound

Robert Froese froese at
Fri Oct 17 05:26:23 PDT 2003


I have the same mobo and the same problem.  Last month, I worked for quite a 
while to resolve this.  There are some patches in progress but after some 
back-and-forth with Orion Hodson (smart FreeBSD guy) we weren't able to solve 
the problem.  It looks like unless you're a programmer we're going to have to 
wait for someone who is a programmer to solve it for us.  In the meantime I 
just bought an old Ensoniq on eBay for $10 and disabled the onboard audio.


On Friday 17 October 2003 08:09 am, Sergey A. Osokin wrote:
> Hello,
> I have an ASUS P4P800 mainbord with ADI AD1985 AC97 codec
> on-board, box good work with 5.1-RELEASE, but
> I haven't sound support.
> $ pciconf -l -v
> ...
> none1 at pci0:31:5:        class=0x040100 card=0x80f31043 chip=0x24d58086
> rev=0x02 hdr=0x00
>     vendor   = 'Intel Corporation'
>     class    = multimedia
>     subclass = audio
> Also I tried to build src/sys/dev/sound/pcm/ac97.[h|c] from
> -CURRENT but its don't help me.
> Any idea?

More information about the freebsd-multimedia mailing list