Problems playing certain wav files

Ken Marx kmarx at vicor.com
Thu Jun 19 15:34:51 PDT 2003


Hi Lucas,

Sorry for the delay getting back to you. My friend, Julian,
just brought his laptop in today.

Sorry for this, but we have a new dimension in behavior space:

On his 5.0 box neither your beep nor my converted beep file
plays. Not only this, but waveplay doesn't even exit!
Running under truss, we see it hang on a call to exit().

Longer files do play fine. So it appears that for small
files the device never flushes. Didn't do any checking
to see what this hypothesized data limit might be.

Likely a 5.0 thing? Sorry couldn't be more helpful.

k.

Lucas Wilcox wrote:
> Cool,
> 
> I think it is good idea to find out how many different setups handle
> these problems, we might find a pattern.
> 
> My desktop which we know atleast plays the prefile is a
> <Creative CT5880-C>.  Does this use the same driver as the 
> <Creative CT5880-A>?
> 
> Lucas
> 
> On Mon, Jun 16, 2003 at 01:43:49PM -0700, Ken Marx wrote:
> 
>>Hi,
>>
>>Just to add another data point:
>>
>>We have a box here:
>>4.8-RELEASE FreeBSD 4.8-RELEASE #1: Thu Apr  3 11:55:56 PST 2003
>>pcm0: <Creative CT5880-A> at io 0x1440 irq 9 (1p/1r/2v channels duplex)
>>
>>that plays *both* pre and post sox'd versions of the beep file fine.
>>
>>I wonder if it's just something with the Maestro chip support.
>>I don't see any diffs between 4.7/8 in pci/maestro*.
>>
>>I know someone who has a maestro-2 chip on his laptop at home,
>>running 5.x. I'll send your file to him and let you know.
>>
>>k
> 
> 
> 

-- 
Ken Marx, kmarx at vicor-nb.com
Each and every one of us is willing to crisp up and achieve closure on 
progress.
		- http://www.bigshed.com/cgi-bin/speak.cgi



More information about the freebsd-multimedia mailing list