Problems recording sound in FreeBSD 5.1

Joachim Strömbergson watchman at
Mon Jul 14 13:52:57 PDT 2003


I've tried to fathom how to record sound from the microphone. But so far 
no success.

Hardware wise, I've got an Asus A7V8X motherboard with built in AC97 
sound. Additionaly I've tried my old SB card (Not at the same time). 
Both the built in AC97 device and the EMU10K device. For example:

FreeBSD Audio Driver (newpcm)
Installed devices:
pcm0: <Creative EMU10K1> at io 0xd400 irq 10 (4p/2r/0v channels duplex 

This does mean that I have two record channels, one of which should be 
the mic, correct?

I'm running FreeBSD 5.1 and KDE3.

However, no matter what tools I try to use, I don't get any sound input 
at all. I have checked the mixer setting so that the mic should be enabled.

Is there ar simple way to directly verify that the mic input works? Has 
anybody experienced similar problems? Anybody knows what might be the 

I have checked the handbook and done some searches of archives as well 
as Google. No luck however. Lots of info on sound output, but nothing on 

Med vänlig hälsning, Cheers!

Joachim Strömbergson
Joachim Strömbergson - ASIC designer, nice to *cute* animals.
     snail:                  phone:                     mail & web:
Sävenäsgatan 5A        +46 31 - 27 98 47          watchman at
416 72 Göteborg        +46 733 75 97 02 

More information about the freebsd-multimedia mailing list