mplayer -tv with bsdbt848

Espen Jervidalo espen at teleport.ch
Fri Dec 5 11:26:50 PST 2003


hi list,

i have been trying to get mplayer working with my Hauppauge WinTV card without success, although it works fine with xawtv and fxtv. 
the command i think should be right is as follows (but i've tried almost any other combination):

mplayer -tv on:driver=bsdbt848:norm=paln:chanlist=europe-west:input=1

sound works, but the picture hangs and looks odd (some green and blue mixed up stuff), still i'm able to recognize the mtv logo f.e.
i tried all kind of video output possibilties, including aa and xv. xv works great with other media on mplayer, so i don't think the problem lies there, but i might be wrong. perhaps some trouble with screen resolutions?

i would really appreciate help on this one. google didn't help much either.
have a nice weekend.

greetings, 
espen jervidalo

bktr0: <BrookTree 878> mem 0xdddfe000-0xdddfefff irq 12 at device 7.0 on pci0
bktr0: Hauppauge Model 38074 B421
bktr0: Hauppauge WinCast/TV, Philips FR1216 PAL FM tuner, remote control.

FreeBSD 5.1-RELEASE #2: Sat Sep 20 17:22:14 CEST 2003
    root at pimp.intern-lan:/usr/src/sys/i386/compile/PIMP
Preloaded elf kernel "/boot/kernel/kernel" at 0xc0708000.
Preloaded elf module "/boot/kernel/nvidia.ko" at 0xc0708244.
Preloaded elf module "/boot/kernel/linux.ko" at 0xc07082f0.
Preloaded elf module "/boot/kernel/acpi.ko" at 0xc070839c.
Timecounter "i8254"  frequency 1193182 Hz
Timecounter "TSC"  frequency 1003655968 Hz
CPU: AMD Duron(tm) Processor (1003.66-MHz 686-class CPU)
  Origin = "AuthenticAMD"  Id = 0x631  Stepping = 1
  Features=0x183fbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR>
  AMD Features=0xc0440000<RSVD,AMIE,DSP,3DNow!>
real memory  = 536805376 (511 MB)
avail memory = 513802240 (490 MB)
Pentium Pro MTRR support enabled
npx0: <math processor> on motherboard
npx0: INT 16 interface
acpi0: <AMIINT VIA_K7  > on motherboard
pcibios: BIOS version 2.10
Using $PIR table, 14 entries at 0xc00f8030
acpi0: power button is handled as a fixed feature programming model.
Timecounter "ACPI-fast"  frequency 3579545 Hz
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
acpi_cpu0: <CPU> on acpi0
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
agp0: <VIA Generic host to PCI bridge> mem 0xe0000000-0xe7ffffff at device 0.0 on pci0
pcib1: <PCI-PCI bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
nvidia0: <RIVA TNT2/TNT2 Pro> mem 0xda000000-0xdbffffff,0xde000000-0xdeffffff irq 11 at device 0.0 on pci1
bktr0: <BrookTree 878> mem 0xdddfe000-0xdddfefff irq 12 at device 7.0 on pci0
bktr0: Hauppauge Model 38074 B421
bktr0: Hauppauge WinCast/TV, Philips FR1216 PAL FM tuner, remote control.
pci0: <multimedia> at device 7.1 (no driver attached)
xl0: <3Com 3c905B-TX Fast Etherlink XL> port 0xe800-0xe87f mem 0xdfffef80-0xdfffefff irq 5 at device 10.0 on pci0
xl0: Ethernet address: 00:50:04:66:14:04
miibus0: <MII bus> on xl0
xlphy0: <3Com internal media interface> on miibus0
xlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
ahc0: <Adaptec 2940 Ultra SCSI adapter> port 0xec00-0xecff mem 0xdffff000-0xdfffffff irq 10 at device 11.0 on pci0
aic7880: Ultra Single Channel A, SCSI Id=7, 16/253 SCBs
pcm0: <CMedia CMI8738> port 0xe400-0xe4ff irq 11 at device 12.0 on pci0
atapci0: <Promise PDC20376 SATA150 controller> port 0xd800-0xd87f,0xdc00-0xdc0f,0xe000-0xe03f mem 0xdffa0000-0xdffbffff,0xdfffd000-0xdfffdfff irq 12 at device 13.0 on pci0
ata2: at 0xdfffd000 on atapci0
ata3: at 0xdfffd000 on atapci0
ata4: at 0xdfffd000 on atapci0
uhci0: <VIA 83C572 USB controller> port 0xd000-0xd01f irq 11 at device 16.0 on pci0
usb0: <VIA 83C572 USB controller> on uhci0
usb0: USB revision 1.0
uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <VIA 83C572 USB controller> port 0xd400-0xd41f irq 5 at device 16.1 on pci0
usb1: <VIA 83C572 USB controller> on uhci1
usb1: USB revision 1.0
uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
ums0: Logitech USB-PS/2 Mouse M-BA47, rev 1.00/1.20, addr 2, iclass 3/1
ums0: 4 buttons and Z dir.
pci0: <serial bus, USB> at device 16.3 (no driver attached)
isab0: <PCI-ISA bridge> at device 17.0 on pci0
isa0: <ISA bus> on isab0
atapci1: <VIA 8235 UDMA133 controller> port 0xfc00-0xfc0f at device 17.1 on pci0
ata0: at 0x1f0 irq 14 on atapci1
ata1: at 0x170 irq 15 on atapci1
acpi_button1: <Sleep Button> on acpi0
fdc0: cmd 3 failed at out byte 1 of 3
sio0 port 0x3f8-0x3ff irq 4 on acpi0
sio0: type 16550A
sio1 port 0x2f8-0x2ff irq 3 on acpi0
sio1: type 16550A
ppc0 port 0x778-0x77b,0x378-0x37f irq 7 drq 3 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/9 bytes threshold
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
fdc0: cmd 3 failed at out byte 1 of 3
pmtimer0 on isa0
fdc0: cannot reserve I/O port range (6 ports)
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounters tick every 10.000 msec
acpi_cpu: throttling enabled, 16 steps (100% to 6.2%), currently 100.0%
ad0: 78167MB <Maxtor 98196H8> [158816/16/63] at ata0-master UDMA100
ad3: 76319MB <WDC WD800BB-00CAA1> [155061/16/63] at ata1-slave UDMA100
acd0: DVD-ROM <CREATIVE DVD-ROM DVD1243E> at ata1-master UDMA33
Mounting root from ufs:/dev/ad3s1a
cd0 at ahc0 bus 0 target 3 lun 0
cd0: <TEAC CD-R55S 1.0R> Removable CD-ROM SCSI-2 device 
cd0: 10.000MB/s transfers (10.000MHz, offset 15)
cd0: Attempt to query device size failed: NOT READY, Medium not present



More information about the freebsd-multimedia mailing list