Help me Gecko! (was: Re: Need help with major printing malfunction)

Ronald F. Guilmette rfg at
Wed Sep 2 23:12:15 UTC 2009

In message <20090902084031.GB26668 at>, you wrote:

>On Wed, Sep 02, 2009 at 12:56:15AM -0700, Ronald F. Guilmette wrote:
>> (Note:  My printer is an old HP Laserjet 5MP.  It speaks Postscript
>> and... I think... HP PCL 5... or maybe 6.  Note also that I was never
>> very fond of all of the complexity of the FreeBSD lpr subsystem...
>> it always seemed like total overkill for a one-user system... so
>> I hacked up my own little Perl script that I call "printit" that just
>> sends whatever it is given to /dev/lp0.  I used that for printing,
>> rather than the lpr command.  In the past, Mozilla/Firefox has always
>> handed by little script pure Postscript... which worked out nicely
>> since my printer groks that... and so I'm kind of assuming that Firefox
>> is still converting pages to Postscript whenever I ask it to print
>> something, but frankly, I'm not even sure of this anymore.)
>I was having similar problems with an HP printer. A network one in my
>case. I'm using lpr with a filter. It used to send postscript verbatim
>to the printer and filter text through a2ps.
>I was having problems with bad fonts and paper sizes(I'm in europe and
>we use A4 here, but the printer insisted in using US letter).
>All the problems vanished when I finally modified the filter to also
>filter all ps through ghostscript and send pcl jobs to the printer.
>My guess is that the printer's postscript interpreter is broken(or has
>some "features"). Try modifying your script to filter things through
>ghostscript and send trhen to the printer in it's own language.
>I use the following ghostscript command line(from stdin to stdout...):
>/usr/local/bin/gs -dSAFER -dBATCH -dNOPAUSE -q -sPAPERSIZE=a4
>-sDEVICE=pxlcolor -sOutputFile=- -
>> P.S.  Before the ``upgrade'' to 3.5.1, things used to print just fine...
>> well...  the text portions did anyway.
>I think firefox started using much fancier postscript after 3.0.x

This does not appear to explain the problem(s) I'm having.  Rather, it
appears that the Postscript (level 3) being generated by the Firefox on
my system is just really really messed up.

I say this because I have been experimenting around, and I just ``printed''
a particular web page ( to a
disk file and then I tried to view that using ghostview/ghostscript and
the text of the ``printed'' page is *still* entirely hosed.

See for yourself!  Here is the web URL again:

and here is the Firefox-printed version of that same page:

Please _do_ try looking at that with any kind of postscript-aware thing
you have available to you (e.g. ghostview) and you'll see that the text
is *seriously* messed up to the point where it is entirely unreadable.

NOTE:  My installed versions of ghostview/ghostscript are:


I am assuming that these tools *do* know how to properly process Postscript
level 3 documents... such as the kind that are allegedly coming out of
Firefox when one tries to printe a web page... so if I look at the ``printed''
file with these tools, and if the pages are still all messed up (as they are)
then it must be because Forefox itself is just plain outputting garbage, right?

So I'm back to square one, and I still need to know:  How do I debug this


P.S.  To be honest, it is stunning to me that whoever did the port of Firefox
3.5.1 to FreeBSD allowed that port to make it into the ports tree when, it
seems, the bleepin' thing can't even print a simple web page.

(And by the way, who is "gecko at" anyway?  Is that a real person,
or just a role?)

More information about the freebsd-mozilla mailing list