Averatec AV1020 review

Bill Paul wpaul at FreeBSD.ORG
Sat Dec 17 21:00:01 PST 2005

I decided to buy myself an early X-mas present, so I picked up a new
laptop: an Averatec 1000 Series AV1020-ED1. I have FreeBSD 6.0 running
on it and just wanted to share my experiences with it in case anyone
else is interested in this system.

This particular laptop isn't that new: it was introduced earlier in
the year, but I procrastinated on buying one for a while hoping that
the price would come down, and to do some research on it. You can
see pictures and basic specs for it here:


Note that there's a 1050 and a 1020 model. The main difference is
that the 1050 has a 1.1Ghz Pentium M processor while the 1020 has
a 1.0Ghz Celeron. I'm not entirely clear on what the real difference
is between them in terms of performance, but I'm satisfied with the
Celeron for now.

The good news is that FreeBSD 6.0 works pretty much out of the box
on this laptop. The ACPI AML seems to have some bugs in it in a few
fringe areas, but the main pieces work correctly (i.e there's no
interrupt routing problems). Key points:

Chipset: Intel ICH4

USB: dual USB 2.0 ports, works out of the box with ehci driver.

Sound: AC97, works out of the box with the snd_ich driver.

Ethernet: RealTek 8139, works out of the box with the rl(4) driver
(I think the 1050 model has Intel fxp(4) ethernet).

Wireless: The 1020's wireless device is a RaLink RT2500. (I think the
1050 has an Intel 2200BG). This works out of the box with the ral(4)
driver and is also supported by the NDISulator. I used it with the ral(4)
driver for a while without any problems, but the wireless network at
work uses WPA2 and AES, and for that I had to use the NDISulator.
This worked ok initially, until I tried wpa_supplicant. I discovered a
bug in ndis_rxeof_eth() in if_ndis.c that caused a hard kernel lockup
due to the driver trying to acquire a serialization spinlock twice in the
same thread. Fortunately, once I fixed this, everything worked as
expected. I used the wireless network at work all day on Friday without
any problems. If you elect to use the NDISulator, remember the following:

	- Download the latest RT2500 Windows driver from www.ralinktech.com.

	- Grab the latest versions of the files in src/sys/compat/ndis
	  and src/sys/dev/if_ndis form the 6.0-STABLE branch or from
	  -current. This will get you the fix for the bug I mentioned

	- If you want to use WPA2, you need to recompile wpa_supplicant
	  with EAPOL support, as follows:

	  # cd /usr/src/usr.sbin/wpa/wpa_supplicant
	  # make install

	  I discovered I needed wpa_supplicant built this way in order
	  for authentication to work right.

The radio on/off button seems to work ok too. It doesn't appear to be
dependent on any special software tricks.

Mouse: Intel Intellimouse touchpad. Works out of the box with the psm(4)
driver, however it only has two buttons. If you use moused(8), edit
/etc/rc.conf and add moused_flags="3" to tell it to emulate the 3rd
button by pressing both buttons at once. If you don't use moused, add
Emulate3Buttons to your xorg.conf file. (I'm still getting used to the
damn touchpad. My old laptop had a nipple mouse. And it had 3 buttons.)

Graphics: Intel 855GM. Works out of the box with Xorg 6.8.2. FreeBSD's
agp(8) driver recognizes the chipset, but there's no DRI support. For
now this doesn't really make much difference to me. One caveat here:
the display supports 640x480, 800x600, 1024x768 and 1280x768 modes,
however Xorg only recognizes 640x480, 800x600 and 1024x768 by default
and will select 1024x768 when you do X -configure. The display ends up
with a really strange aspect ratio in this mode, however, so you really
want 1280x768. You can convince Xorg to use this mode if you edit your
xorg.conf file a little:

	- In the "Monitor" subsection, add the following lines:

	  HorizSync 31.5-48.5
	  VertRefresh 40-70
	  ModeLine "1280x768" 80.14 1280 1344 1480 1680 768 769 772 795

	- For each "Display" subsection, add the following line:

	  Modes   "1280x768" "1024x768" "800x600" "640x480"

With these changes, the X server defaults to 1280x768. I also set the
DefaultDepth to 24 bits. The display is very pretty.

Pccard slot: just works. Tried a couple of my cardbus wireless cards.

DVD/CD drive: just works.

Stuff that doesn't work:

Modem: it's a softmodem. No joy there. I don't mind though since I happen
to have a standard PCMCIA modem card.

Suspend mode: trying to suspend with zzz just makes the laptop freeze
up and it never recovers until I power cycle it. I sort of expected this
(suspend didn't work on my previous laptop either) and I'm not really that
broken up about it.

Special volume control keys: these seem to have no effect. The screen
brightness controls do work though.

On the whole, I'm pretty happy with the laptop. All the important stuff
works without any serious issues. There's one gotcha that potential
buyers should be aware of however, which isn't a problem with the laptop
per-se, but which may be an issue for some. The laptop does not come with
a recovery CD or DVD. Instead, it has a Phoenix Recovery partition at
the end of the disk, which can be used to overwrite the installed
Windows XP image with a fresh copy. Unfortunately, the version of the
software included on the laptop does not include support for burning your
own recovery CD or DVD. And Averatec's "policy" is that they won't give
you one if the laptop comes with a recovery partition. I contacted someone
at Averatec about this on Friday but haven't heard back from them yet.

In the meantime, if you want to back up the recovery software, be aware
of the following:

	- The recovery partition occupies the last 3GB of the disk,
	  and has a partition type of 73. You can probably make an
	  image copy of it with dd(1), but make sure you have room
	  for it.

	- You normally access the recovery software by pressing the F4
	  key while the laptop boots. This keypress is _not_ interpreted
	  by the BIOS. Instead, it's interpreted by the boot block on
	  the hard disk. If you install the FreeBSD boot loader, it will
	  trash this boot block, so try to save it as well.


-Bill Paul            (510) 749-2329 | Senior Engineer, Master of Unix-Fu
                 wpaul at windriver.com | Wind River Systems
              <adamw> you're just BEGGING to face the moose

More information about the freebsd-mobile mailing list