BCM5354 D-Link DIR-320

Alexandr Rybalko ray at dlink.ua
Wed Jun 3 10:34:59 UTC 2009

Hi to All!

BFE + RoboSwitch - WORKED
USB OHCI+EHCI - NOT DONE (sometime see vendor string, sometime not)
UART console - WORKED (to mach hardcoded values)

entry: mips_init()
Cache info:
  picache_stride    = 4096
  picache_loopcount = 4
  pdcache_stride    = 4096
  pdcache_loopcount = 4
cpu0: Broadcom processor v41.144
  MMU: Standard TLB, 32 entries
  L1 i-cache: 4 ways of 256 sets, 16 bytes per line
  L1 d-cache: 2 ways of 512 sets, 16 bytes per line
Va=0xc0000000 Ve=ffffc000
init kernel_segmap va >> = 768 nkpt:120
avail_start:0x439000 avail_end:0x2000000
KDB: debugger backends: ddb
KDB: current backend: ddb
hz=100 cyl_per_hz:132000 cyl_per_usec:132 freq:132000000 cyl_per_hz:1320000 cyl_per_sec:132000000
Copyright (c) 1992-2009 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 8.0-CURRENT #533 r120:192973MS: Wed Jun  3 12:33:29 EEST 2009
    root at terran.mk.farlep.net:/usr/home/ray/Projects/MIPS/FreeBSD/obj/mips/usr/home/ray/Projects/MIPS/FreeBSD/src/sys/BCM4704
real memory  = 32763904 (31996K bytes)
Physical memory chunk(s):
0x00439000 - 0x01f44fff, 28360704 bytes (6924 pages)
avail memory = 28008448 (26MB)
null: <null device, zero device>
nfslock: pseudo-device
mem: <memory>
nexus0: <MIPS32 root nexus>
clock0: <Generic MIPS32 ticker> on nexus0
clock0: [FILTER]
siba0: start 18000000 len 00010000
siba0: idlo = 600422dd
siba0: idhi = 42439004
siba0:  chipcore id = 00000800
siba0: ccid = 07025354, cc_id = 5354, cc_rev = 0002
siba0: 7 cores detected.
siba0: after remapping: start 18000000 len 00007000
siba0: <Sonics SiliconBackplane rev 0x0> at mem 0x18000000-0x18006fff on nexus0
siba_attach: entry
siba_setup_devinfo: core=0 Vendor=4243 Dev=800 Rev=014
siba0: <ChipCommon> corid=0800 regions count 4 0=18000000x1000 1=1fc00000x400000 2=1c000000x2000000 3=1a000000x2000000
siba_setup_devinfo: core=1 Vendor=4243 Dev=806 Rev=009
siba0: <Ethernet core> corid=0806 regions count 1 0=18001000x1000
siba_setup_devinfo: core=2 Vendor=4243 Dev=816 Rev=008
siba0: <MIPS 3302 core> corid=0816 regions count 1 0=18002000x1000
siba_setup_devinfo: core=3 Vendor=4243 Dev=819 Rev=002
siba0: <USB 2.0 Host> corid=0819 regions count=2 func=1 base 18003000x0200 func=2 base 18003800x0100
siba_setup_devinfo: core=4 Vendor=4243 Dev=80f Rev=004
siba0: <SDRAM/DDR controller> corid=080f regions count 4 0=18004000x1000 1=00000000x8000000 2=10000000x8000000 3=80000000x20000000
siba_setup_devinfo: core=5 Vendor=4243 Dev=812 Rev=00d
siba0: <IEEE 802.11> corid=0812 regions count 1 0=18005000x1000
siba_setup_devinfo: core=6 Vendor=4243 Dev=81c Rev=002
siba0: <Roboswitch> corid=081c regions count 1 0=18006000x1000
siba_cc0: <ChipCommon core> at mem 0x18000000-0x18000fff irq 0 on siba0
siba_cc0: [FILTER]
siba_cc0: Core Revision 20
siba_cc0: Number of UARTs 2
siba_cc0: UARTs clock select 0x08
siba_cc0: UART use internal divided clock
siba_cc0: UART use GPIO pins 15:12
siba_cc0: Unknown ExtBus type
siba_cc0: Parallel flash
siba_cc0: Type of PLL 0x00
siba_cc0: JTAG Master Present
siba_cc0: PMU Present
uart0: [FILTER]
uart0: fast interrupt
uart0: console (115200,n,8,1)
siba_cc_attach: done
bfe0: <Broadcom 44xx Ethernet Chip> at mem 0x18001000-0x18001fff irq 1 on siba0
bfe_robo_config_vlan: Add port 1 untagged  to VLAN=1
bfe_robo_config_vlan: Add port 2 untagged  to VLAN=1
bfe_robo_config_vlan: Add port 3 untagged  to VLAN=1
bfe_robo_config_vlan: Add port 4 untagged  to VLAN=1
bfe_robo_config_vlan: Add port 5 untagged CPU MII to VLAN=1
bfe_robo_config_vlan: Add port 0 untagged  to VLAN=2
bfe_robo_config_vlan: Add port 5 tagged CPU MII to VLAN=2
miibus0: <MII bus> on bfe0
bfeswitch0: <BCM5325 10/100baseTX Switch PHY> PHY 0 on miibus0
bfeswitch0:  100baseTX-FDX
bfe0: Ethernet address: 00:1b:11:31:df:0a
bfe0: [MPSAFE]
bfe0: [ITHREAD]
siba_mips0: <MIPS 3302 processor> at mem 0x18002000-0x18002fff on siba0
siba_mips0: SBIPSFlag=03020100
siba_mips0: SBIPSFlagHigh=00000000
siba_mips0: SBIntVec=000000f0
ohci0: <SiBa integrated OHCI controller> at mem 0x18003000-0x18003fff irq 4 on siba0
ohci0: [MPSAFE]
ohci0: [ITHREAD]
usbus1: EHCI version 1.0
usbus1: set host controller mode
usbus1 on ohci0
usbus0 on ohci0
siba_sdram0: <SDRAM/DDR core> at mem 0x18004000-0x18004fff on siba0
siba0: <IEEE 802.11> at device 5 (no driver attached)
siba0: <Roboswitch> at device 6 (no driver attached)
Device configuration finished.
Timecounter "MIPS32" frequency 132000000 Hz quality 800
Timecounters tick every 10.000 msec
usbus0: 12Mbps Full Speed USB v1.0
usbus1: 480Mbps High Speed USB v2.0
bootpc_init: wired to interface 'bfe0'
Sending DHCP Discover packet from interface bfe0 (00:1b:11:31:df:0a)
ugen0.1: <Broadcom OHCI v> at usbus0
uhub0: <Broadcom OHCI v OHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus0
ugen1.1: <Broadcom EHCI v> at usbus1
uhub1: <Broadcom EHCI v EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus1
Received DHCP Offer packet on bfe0 from (accepted) (no root path)
uhub0: 2 ports with 2 removable, self powered
uhub1: 2 ports with 2 removable, self powered
ugen1.2: <vendor 0x0000> at usbus1
Sending DHCP Request packet from interface bfe0 (00:1b:11:31:df:0a)
Received DHCP Ack packet on bfe0 from (accepted) (got root path)
bfe0 at server
subnet mask rootfs 
Adjusted interface bfe0
Trying to mount root from nfs:
warning: no time-of-day clock registered, system time will not be set accurately
warning: no time-of-day clock registered, system time will not be set accurately
start_init: trying /sbin/init
Interface bfe0 IP-Address Broadcast 

Alexandr Rybalko <ray at dlink.ua>

More information about the freebsd-mips mailing list