getting tomcat running

Roberto Nunnari roberto.nunnari at
Thu Feb 5 00:13:34 PST 2009

Hi Chuck, see my comments below..

Chuck Robey ha scritto:
> Hash: SHA1
> Roberto Nunnari wrote:
>> I agree. Also, remember to add this line to your /etc/rc.conf:
>> tomcat55_enable="YES"
>> then, you can start your tomcat, with:
>> /usr/local/etc/rc.d/tomcatxx
>> where xx stand for your tomcat version.
> Funny, I'm actually anxiously *trying* to be wrong here.
> First, I started out with a server.xml which I'd modified to have the "8080"
> connector modified to read "80" only, and it seems that nothing else I've done
> has changed it, because I've been rechecking it at every turn, it stays still at
> 80.  I even decided to try the 8080 *anyhow*, by putting it in the lookup URL,
> but that hasn't helped.  I wasn't really aware about how the apache server and
> tomcat interwork.  I got that info last night.  If I have apache working, I have
> my little demo url showing up.  If I don't have the apache server working, then
> the browser tells me that it can't find anything at all at localhost.  I'd
> configured tomcat to default to a directory listing, it does that, but I tried
> to turn "listings" off, it STILL gives me directory listings to begin with.

You don't need at all apache httpd.. especially if you are in a
developer environment. Tomcat is always able to serve pages, also
without apache httpd.

..maybe this is too naive.. but it sounds like you don't specify the
port number in the browser.. :-O
If you configure tomcat to run on port 8080, then in the browser, your
URL should look like something like
and if you deploy an app named myapp, then:

> I'm not sure what word to use in the /etc/rc.conf.  I've had tomcat6_enable set
> to YES from the beginning, but I'm not sure it shouldn't be tomcat, tomcat60, or
> maybe something with periods in it.  I need help on that, no script seems to be
> helping me.

Yes.. I should have got it from the beginning, since you said you get
some output in the logs from tomcat.. if you dont have that in rc.conf
then tomcat is never even told to start..

> Was your comment about setting tomcat55 a mistake, or a real thing?  I don't
> want to sound like some nitpicker, I'm just so desperate for a fix, I really
> don't know the answer.

Yes. I wrote tomcat55 because I have tomcat55 installed on the server
and I forgot to adapt it to your case.

> What I did about adding the APR, it was because of the log entry, I was looking
> for any possible answer.  I'm still thinking that I need an answer about the
> missing library, and how come the stdout log entry tells me that my
> java.library.path is not bringing in the libs.  I need to fix whatever sets that
> java.library.path.  Is that configured somewhere?
> Thanks hugely for the help!

I think, you should just deinstall all extra stuff (tomcat-native,
apr, etc..) you installed, and once tomcat started, point your
browser to the right URL (see above about the port number).
If that still doesn't work, deinstall tomcat, remove the
tomcat directory, to remove all your editing in the tomcat
configuration, and then reinstall tomcat, make sure you still
have that line in rc.conf, start tomcat, and point your browser
to http://localhost:8180/


>> Robi
>> Pieter de Goeje ha scritto:
>>> On Wednesday 04 February 2009 03:13:44 Chuck Robey wrote:
>>>> I can't get my tomcat6 working.  I found an interesting item in the
>>>> /usr/local/apache-tomcat6.0/logs/stdout.log, so I'm checking out that it
>>>> says that it wants a libtcnative.  Here's the log entry:
>>>> INFO: The APR based Apache Tomcat Native library which allows optimal
>>>> performance in production environments was not found on the
>>>> java.library.path:
>>>> /usr/local/jdk1.6.0/jre/lib/i386/server:/usr/local/jdk1.6.0/jre/lib/i386:
>>>> /usr/local/jdk1.6.0/jre/../lib/i386:/usr/lib:/usr/X11R7.4/lib:/usr/local/li
>>>> b: /usr/java/packages/lib/i386:/lib:/usr/lib:/usr/local/lib
>>>> So, I found a www/tomcat-native port which installs the
>>>> library, and I installed that, but the error above, from the stdout.log
>>>> file, doesn't change, it still can't find the library.  What does
>>>> tomcat6
>>>> refer to, to find it's libraries?  The libtcnative it installs is
>>>> going into /usr/local/lib, it's on that list, ldconfig -r finds it fine.
>>> The "Apache Tomcat Native" library really isn't needed to run tomcat.
>>> The library speeds up serving of static content. I bet your tomcat
>>> started fine, and is listening on port 8180. Are you sure you
>>> restarted tomcat after you intstalled tomcat-native?
>>> For development I recommend downloading the latest tomcat, extracting
>>> it in your homedir. Then simply:
>>> cd apache-tomcat-6.x.y
>>> export JAVA_HOME=/usr/local/jdk1.6.0
>>> ./bin/
>>> You can then also configure eclipse to automatically deploy your
>>> applications to this tomcat.
>>>> I looked at that list above, I know it's nothing I ever put together,
>>>> some
>>>> port's done that.  Any idea from where?   Maybe I should put the
>>>> /usr/local/lib higher in that list?  I mean, I haven't got any
>>>> /usr/java,
>>>> maybe it's seeing a bad entry like that and stopping the entry
>>>> reading at
>>>> that point.  I need to find that list.
> Version: GnuPG v2.0.9 (FreeBSD)
> Comment: Using GnuPG with Mozilla -
> 5msAoKTl93gXEpprCG6LwZEFoJjmLhmF
> =c/lY

Roberto Nunnari
Servizi Informatici SUPSI-DTI
SUPSI-DTI - Via Cantonale - 6928 Manno - Switzerland
email: mailto:roberto.nunnari at
tel: +41-58-6666561

More information about the freebsd-java mailing list