jdk16 and -fno-tree-vrp

Björn König bkoenig at alpha-tierchen.de
Mon Nov 12 06:04:20 PST 2007


I tried to investigate the recently discussed problem with jdk16 where you
suggested to add -fno-tree-vrp to CFLAGS, but I can't reconstruct it. I
used 7.0-CURRENT (GENERIC without debugging stuff) and ports both from
October 1st 2007. jdk-6u1 built and installed without problems for me. I
also tried jdk-6u2 without "success"; it worked fine.

So I strongly disapprove the change of GCC to not use tree-vrp by default
and I want to suggest that you change it back. GCC 4.2 seem to have many
bugs and I think it's the wrong way to change it's default behaviour to
work around these bugs, because this reveals other bugs.

If you are still able to reproduce the error (e.g. with explicit
-ftree-vrp) then I would be glad if you can provide detailed information
about the environment. I want to get the same error, because I'm searching
for a more suitable solution, e.g. a better GCC patch.


More information about the freebsd-java mailing list