Sound Control

David Wassman myfreebsd at
Mon Sep 19 17:13:05 PDT 2005

I cannot get any application that I run to control the volume. I get sound but 
am not able to adust the volume level. So far the following apps have shown 
this problem:
Noatun (no sound at all so may be different issue)

I am running FreeBSD 5.4/KDE 3.2.4 with a Sound Blaster Live! sound card.
My sndstat:
pcm0: <Creative EMU10K1> at io 0xb800 irq 11 kld snd_emu10k1 (4p/2r/4v 
channels duplex default)
so the card is recognized. I have adjusted the virtual channels in sysctl.conf 
and the sndstat shows there are 4v chanels.
I have both esound and arts. Thought this may be an issue but both are 
dependencies of KDE-Multimedia

So far I have tried the following:
1)	Updating ports and ran portmanager. No effect.
2)	Changed KControl->Sound System to use the following in all combinations:
		Threaded OSS
		Full Duplex
	No avail.	
3)	Tried OSS drivers instead of FreeBSD native. Could not initialize the card. 
4)	Rebuilt both esound and arts. No effect

I have googled this yet cannot find any post with similar issue (except one in 
which the onboard card was not deactivated. I do not have an onboard). 

The only other thing I could think of is to update the whole system in 
buildworld. Not really excited about this option as everything else is 
working great (don't want to mess with it). I use this as my primary desktop 
so I don't want to be down for that long.

Anyone have any ideas or a direction to point me in? 

Thanks in advance,

More information about the freebsd-hardware mailing list