4D+ Mouse

Mr Green callipygous at internode.on.net
Fri Sep 9 20:33:45 PDT 2005

I also had a similar problem with a USB MS Wireless Optical mouse.  I could
not get it to work, and have also talked to people who have had the same
mouse and not been able to get it to work.  It is detected by the
system, but regardless of the driver chosen, nothing happens.  Likewise
it works on other operating systems.

On Fri, Sep 09, 2005 at 05:23:32PM -0700, Dan Strick wrote:
> Fearing that 3-button mice might soon become extinct, I just bought a
> bunch of cheap ones for my inventory.  They were advertised as "LOGITECH"
> but are labeled "Labtec".  During the bootstrap configuration monologue,
> the psm driver reports "psm0: model 4D+ Mouse, device ID 8".
> I tried two of these mice with FreeBSD 5.4 and neither worked with moused.
> The console went crazy when I moved the mouse.  Moused worked a little
> better if I specified the "ps/2" protocol instead of "auto", but it still
> jerked the cursor around a bit anyway.  I discovered that if I booted the
> system with a working ps/2 mouse attached and then connected the Labtec
> mouse in place of the working mouse, then the Labtec mouse worked just
> fine even with the "auto" protocol.
> I added this line:
> 	hint.psm.0.flags="0x200"
> to /boot/device.hints.  This is the NOIDPROBE bit.  It apparently tells
> the psm driver to ignore whatever the mouse says about itself and assume
> it is a generic ps/2 mouse.  The psm driver now reports:
> 	psm0: model Generic PS/2 mouse, device ID 0
> during bootstrap and the Labtec mice seem to work ok.
> I looked in the psm driver.  It seems to think it knows something special
> about A4 Tech 4D+ mice.  I didn't study the details or even verify that
> this is what it thinks my Labtec mice are.
> Can someone shed some light on this problem?  Is choosing an off-brand
> ps/2 mouse something of a crapshoot?  I never had such a problem before.
> (P.S. This problem may be specific to FreeBSD.  RH FC4 Linux has no
> problem with the mouse.  I bet that MS windows doesn't either.  Does this
> count as a bug in the FreeBSD 5.4 psm driver or is it just a fact of life?)
> Dan Strick
> _______________________________________________
> freebsd-hardware at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-hardware
> To unsubscribe, send any mail to "freebsd-hardware-unsubscribe at freebsd.org"

More information about the freebsd-hardware mailing list