HP DL360 G3 Hangs on Disk Removal

Paul Lutt paul.lutt at fluke.com
Fri Jan 23 09:35:57 PST 2004

I have been evaluating FreeBSD Release-5.2 on an HP DL360 G3 for possible
deployment on several new servers.  Everything was looking good until I
tried pulling a disk drive from the RAID 1 pair while the system was
running.  I wanted to verify that it would continue on gracefully.

What I got was a system that wasn't totally locked up, but it could not
perform any disk access.  I had a shell open on the console.  Pressing
enter would bring up a new prompt.  Trying to do anything that required
reading the disk would cause the shell to hang.

I could go to another console window and get a login prompt, but as soon
as I entered the login name, the login process would hang.

If I power cycle the server, it comes back up OK and notes the failed
disk.  If I insert the disk while the system is running, it hangs in the
same manner as when I removed the disk.  If I reboot, the system rebuilds
the disk and everything is OK.

I tried this test a couple of times and got the same results.  Sometimes
the CISS driver would note the changes in syslog, but the system would
still hang.

I tried installing FreeBSD Release-4.9 and got identical results.

I have a Dell server with PERC RAID running FreeBSD Release-5.1.  I tried
the same test on it and it performed flawlessly, logging the removal of
the disk and the re-insertion without a single hiccup.

Unfortunately, I need to get this to work on the HP Proliant hardware.
Does anyone have any suggestions on how to get this to work reliably?  If
not, I will have to abandon FreeBSD and install some flavor of Linux on
the servers instead.

Thanks in advance.

Paul Lutt
Fluke Corporation
paul.lutt at fluke.com

More information about the freebsd-hardware mailing list