pcm midi uarts? Do they work?

Ethan telmnstr at 757.org
Sat Jan 17 16:48:09 PST 2004

Hello all,

 I am trying to develop an application to communicate with an external
compressor/limiter via midi. I've written some small apps on a different
box that worked fine, but the system is long gone.

 My kernel is compiled with device pcm, and there are two sound cards
which both work fine for standard digital audio recording and playback.

 The /dev/midi0 and midi1, and sequencer0 and sequencer1 do not seem to

cat: /dev/midi0: Device not configured
cat: /dev/midi1: Device not configured
cat: /dev/sequencer0: Device not configured

And my program:
Error: cannot open /dev/midi0

Are the midi devices supposed to work?

radio# cat /dev/sndstat
FreeBSD Audio Driver (newpcm)
Installed devices:
pcm0: <AudioPCI ES1373-B> at io 0xde80 irq 10 (1p/1r/0v channels duplex)
pcm1: <Creative CT5880-C> at io 0xdf00 irq 9 (1p/1r/0v channels duplex)

inodes seem proper:

crw-rw-rw- 1 root wheel 30, 2 Jan 9 2003 midi0
crw-rw-rw- 1 root wheel 30, 4 Jan 9 2003 audio0.0
crw-rw-rw- 1 root wheel 30, 0x00010004 Jan 9 2003 audio0.1

I tried adding in the sbcmidi stuff in an attempt that maybe the midi uart
still lived at the 330 memory address, but no go...

Any thoughts / suggestions? I'm stuck...

More information about the freebsd-hardware mailing list