behaviour changes in mdconfig? or something related?

Samuel Martín Moro faust64 at
Wed Aug 4 13:05:52 UTC 2010


I started this thread in the freebsd-questions mailing list.
But since I'm quite sure it's not a bsdlabel problem, I might find better
answers here.

We have a script that buids custom FreeBSD releases.
This code works on 4.7, 5.4, 5.5, 6.2, 7.1 and 7.2.
I want to make it work with FreeBSD-8.1.

Brievly, it works like that:

having minimum4, the following disktab layout:

dd if=/dev/zero of=bootfile.img bs=18k count=4096
dev=`mdconfig -a -t vnode -f bootfile.img`
bsdlabel -w -B -b $GENPATH/boot/boot /dev/$dev minimum4
newfs -O1 -i 4096 -o space -m 1 /dev/${dev}c
mount /dev/${dev}c /mnt
(cd cdroot ; find . | cpio -dump /mnt)

When bsdlabelling, I got these warnings:
bsdlabel: partition c doesn't cover the whole unit!
bsdlabel: An incorrect partition c may cause problems for standard system

But it never was a problem for older releases.

Since 8.1 (8.0?), after calling bsdlabel, I still have /dev/${dev}a,
but/dev/${dev}c doesn't show up anymore.

I tried mounting a 7.2-generated image (where I had both md0a and md0c) on a
8.1 host, and only had md0a listed in devs.
I tried mounting a 8.1-generated image (where I had only /dev/md0a) on a 7.2
host, and /dev/md0c finally appeard.

So, is it possible to / how could I make ${dev}c appear on 8.1, like it was
in previous releases?


Samuel Martín Moro
{EPITECH.} tek4
CamTrace S.A.S
  (+033) 1 41 38 37 60
  1 Allée de la Venelle
  92150 Suresnes

"Nobody wants to say how this works.
  Maybe nobody knows ..."

More information about the freebsd-hackers mailing list