Help troubleshooting...

M. Warner Losh imp at
Mon Oct 26 11:53:07 UTC 2009

In message: <200910260959.20772.hselasky at>
            Hans Petter Selasky <hselasky at> writes:
: On Monday 26 October 2009 01:05:03 non at wrote:
: > M. Warner Losh wrote:
: > > I have a usb stick (8GB) on it.  This stick has about 5GB of junk on
: > > it at this point.
: > >
: > > I tried to do 'cat * > /dev/null' recently, to measure how fast it
: > > goes.  It got about 1GB into the drive and then I got device missing
: > > messages.
: > >
: > > So devfs thinks the device went missing:
: >
: > Warner-san, maybe it is caused by the hardware problem on the USB flash
: > memory. Some chip on the memory might have too much heat when you access
: > the memory at fast rate. Then it stops working.
: >
: What happens if you read from two USB disks at the same time?

I know that the august 25th version failed badly when I tried to burn
DVDs from a USB drive to a USB attached DVD burner.  This used to work

: If the device went missing the USB HUB signalled that. This is maybe an 
: indication that the USB firmware on the device crashed. Maybe this is due to 
: heat, or unhandled race conditions when the load goes high.

This same flash drive will do 20MB sustained on windows without a
glitch using similar commands.

: Try using "dd" and vary the block size from 512 to 65536 bytes. Does it stop 
: working with all block sizes over time?

Once I get the message I posted, it is lights out for da0.  No further
access to the drive works at all.


More information about the freebsd-hackers mailing list