pccard0: Card has no functions!

Marian Cerny jojo at matfyz.cz
Thu Aug 16 16:10:19 PDT 2007


I have Nokia Card Phone 2.0 (on a supported HW list) in a PCMCIA to PCI
adapter. I have used this combination some time ago (2-3 years) and it worked
without any problems. I don't remember what FreeBSD version I used that time.

I tried to get it working under FreeBSD 6.2R today but was not
successful. I can see those messages after boot:

Status is 0x30000410
cbb0: card inserted: event=0x00000000, state=30000410
pccard0: chip_socket_enable
cbb0: cbb_power: 5V
pccard0: read_cis
cis mem map 0xe7286000 (resource: 0xfe310000)
pccard0: CIS tuple chain:
cis mem map e7286000
CISTPL_LINKTARGET expected, code ff observed
pccard0: check_cis_quirks
pccard0: Card has no functions!
cbb0: PC Card card activation failed

I have spent hours on google trying to find any solution how to make it
work. I have played with the hw.cbb.start_memory, tried to disable acpi,
recompiled a GENERIC kernel... Any help would be wellcomed.

Relevant messages from dmesg (full dmesg at

acpi0: <A M I OEMXSDT> on motherboard
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib5: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci5: <ACPI PCI bus> on pcib5
cbb0: <RF5C475 PCI-CardBus Bridge> irq 23 at device 2.0 on pci5
cbb0: Found memory at fe300000
cbb0: Secondary bus is 6
cardbus0: <CardBus bus> on cbb0
pccard0: <16-bit PCCard bus> on cbb0


pciconf -lv:
cbb0 at pci5:2:0:  class=0x060700 card=0x010114ef chip=0x04751180 rev=0x80 hdr=0x02
    vendor   = 'Ricoh Co Ltd'
    device   = 'RL5c475 CardBus Controller'
    class    = bridge
    subclass = PCI-CardBus


Marian Cerny

More information about the freebsd-hackers mailing list