open ("/dev/lpt0" ...) hangup solved

george+freebsd at george+freebsd at
Sat Jul 22 17:03:27 UTC 2006

As was suggested, the problem is that when the system automatically
brings up the plip0 interface, it grabs the ppbus and doesn't let it
go until someone takes the interface down.  I now believe this problem
was present even in 5.3, but I didn't see it because I routinely
compiled custom 5.x kernels, always without plip.

So the real simple fix is to prevent the plip0 interface from coming
up.  I thought the simple fix for this was to put:


into my rc.conf.  But it still came up anyway.  So I put:

network_interfaces="sis0 re0 lo0"

in rc.conf, explicitly excluding plip0.  But plip0 still came up!
What am I doing wrong now?

(When I manually "ifconfig plip0 down", the whole printing problem
is solved.)

Whatever the correct way for keeping plip0 off the list of interfaces
automagically brought up is, I suggest it should go into
/etc/defaults/rc.conf to keep future losers like me from running into
this problem.                         -- George Mitchell

More information about the freebsd-hackers mailing list