dump causing system idle

kylin fierykylin at gmail.com
Sun Nov 27 02:17:16 GMT 2005

i am in terrible trouble when trying to dumping my kernel module 's fault
i add dump device and dump dir in rc.conf and dumpon ...
but when the first reboot after the panic&dumpon freebsd 53 idles on
WARNING: / was not properly dismounted
 start_init: trying /sbin/init
i fscked this slice on another freebsd, i tried another clean kernel
,i tried the single user mode ,but no use ,the init died there
why? below i note the panic&dump info and the mesg when start up:
below is the panic&dump info:
fatal trap 12: page fault while in kernel mode
fault virtual address   = 0x0
fault code              = supervisor read, page not present
instruction pointer     = 0x8:0xc066cdb4
stack pointer           = 0x10:0xcc7c5bf8
frame pointer           = 0x10:0xcc7c5bf8
node segment            = base 0x0, limit 0xfffff, type 0x1b
                       = DPL 0, pres 1, def32 1, gran 1
processor eflags        = interrupt enabled, IOPL = 0
current process         = 1033 (kldload)
trap number             = 12
panic: page fault
ptime: 4h21m6s
dumping 255 MB

2 here is the start up message
ad0: 1 secs/int, 1 depth queue, WDMA2
GEOM: new disk ad0
ar: FreeBSD check1 failed
ata1-master: pio=0x0c wdma=0x22 udma=0xffffffff cable=40pin
ata1-master: setting PIO4 on Intel PIIX4 chip
acd0: <Virtual CD/> DVDROM drive at ata1 as master
acd0:  128KB buffer, PIO4
acd0: Reads: CDR, CDRW, CDDA, DVDROM, DVDR, DVDRAM, packet
acd0: Writes:
acd0: Audio: play, 255 volume levels
acd0: Mechanism: ejectable tray, lock protected
acd0: Medium: CD-ROM unknown
[0] f:80 typ:165 s(CHS):0/1/1 e(CHS):1023/15/63 s:63 l:4095441
[1] f:00 typ:165 s(CHS):1023/15/63 e(CHS):1023/15/63 s:4095504 l:29458800
[2] f:00 typ:0 s(CHS):0/0/0 e(CHS):0/0/0 s:0 l:0
[3] f:00 typ:0 s(CHS):0/0/0 e(CHS):0/0/0 s:0 l:0
GEOM: Configure ad0s1, start 32256 length 2096865792 end 2096898047
GEOM: Configure ad0s2, start 2096898048 length 15082905600 end 17179803647
GEOM: Configure ad0s1a, start 268435456 length 1827667968 end 2096103423
GEOM: Configure ad0s1b, start 0 length 268435456 end 268435455
GEOM: Configure ad0s1c, start 0 length 2096865792 end 2096865791
Mounting root from ufs:/dev/ad0s1a
WARNING: / was not properly dismounted
start_init: trying /sbin/init

we who r about to die,salute u!

More information about the freebsd-hackers mailing list