FreeBSD ported to the XBox!

Ed Schouten ed at
Wed Jul 27 13:41:57 GMT 2005

* loader <loader at> wrote:
> I got my XBOX with an Aladdin modchip. Today I downloaded the LiveCD
> and tried to boot from it, but failed. (I don't have the Cromwell BIOS
> installed on my XBOX ). Then I booted XBOX with GentooX install CD (Home edition),
> and replaced GentooX CD with FreeBSD XBOX live CD after it booted into 
> GentooX Loader, selected CD option, then the XBOX was try to boot from it, 
> I can see there's four choices (FreeBSD 5.4 ... CD/HDD, 
> FreeBSD 6.0-BETA1 ... CD/HDD). I tried all of them, it just stopped there, 
> it didn't show any FreeBSD boot messages.

Well, the GentooX bootloader doesn't support ELF files yet. If I recall
correctly, Rink has also put a patched Cromwell binary on the CD, so you
could chainload it from within the GentooX loader. Good luck!

 Ed Schouten <ed at>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-hackers mailing list