Help debugging mysterious freezing (5.4)

alexander arundel at
Fri Jul 22 12:44:34 GMT 2005

I had the very same problem under 5.4-STABLE. I tried a lot to get rid of the
problem (switch RAM, recompile ports && world, change nvidia driver settings,

What solved the problem for me was to remove a hardrive witch I used as swap

ad5: 810MB <QUANTUM TRB850A A04.5B> at ata2-slave WDMA2

Now I'm using a different swap partition. It shares a harddrive with my
root (/) partition. After that I haven't experienced any lookups anymore.

I asume the hardrive which I was using as a swap aprtition was either broken,
had wrong sectors or the FBSD driver for it was buggy.

Hope that helps you a bit.


On Fri Jul 22 05, Phil wrote:
> I'm trying to debug a strange freezing issue on my file-server, but  
> I'm not quite sure how to go about it.
> My hardware setup is:
> -Rather old P3
> -5 HDDs (All Seagate, around 1 year old)
> --4 of those drives (all apart from the system drive) are connected  
> to a Promise Ultra100 TX2 PCI controller card
> -vr network card
> My software setup is:
> -FreeBSD 5.4
> -Custom kernel:
> --Workaround from i386/73706 applied
> --No APIC
>   (Required for my vr network card to work)
> --Device hints disabling ACPI and APIC
> -The bare essentials running for a NFS/SMB server
> What happens, is that the machine will freeze (no HDD activity,  
> doesn't respond to keyboard, doesn't respond to network, etc.),  
> usually when there's a lot of HDD activity.
> I don't get any console error messages, helpful log messages, or  
> anything - the machine just halts and I have to give it a hard reboot.
> It's been working fine for almost a week (sharing drives over NFS/ 
> SMB), when this started happening (I didn't start anything special,  
> in fact, I wasn't even using it).
> The last couple of times this has happened, has been during a fsck  
> (during phase 1) of the drives after I'd noticed it had frozen. The  
> next time I ran fsck, it completed fine, no errors.
> It doesn't seem to freeze on one particular drive - SMART status for  
> the drives is fine, and I've run a few tests - all pass. The IDE  
> cables are all 80-pin, nice, stiff, new ones as well.
> If this is a hardware problem (which it looks to be), I'd at least  
> like to know where.
> Thanks,
>                     -Phil
> _______________________________________________
> freebsd-hackers at mailing list
> To unsubscribe, send any mail to "freebsd-hackers-unsubscribe at"

More information about the freebsd-hackers mailing list