annoying HAL installation bug and workaround

MandrakeRoot mandrakeroot at
Tue Apr 15 18:23:27 UTC 2008

Hello. I have installed Gnome on my Freebsd 7 using

pkg_add gnome2  

which is the recommended  way. In the Gnome Freebsd project documentation .

The problem is that the hald package is poorly installed by this method 
and this issue i found also on some obscure older forums. What happens 
in fact it is that the haldaemon user is not created and hald cannot 
start. What is annoying is that although i launched hald with the 
verbose option it did not spit out any error until i decided to launch 
it overriding the daemonise option.

 On that older forum it was assumed that it was a bug in the sysinstall 
procedure but in fact i think it comes from installing from the binaries 
as i did not install gnome2 from the beginning on my comp . The 
workaround i used and which is not my discovery was to uninstall the 
package and reinstall from source. I think this is a bug that should be 
solved as soon as possible as HAL seems to be fundamental for a good 
functioning of gnome.

Strangely another issue was suddenly solved . I had not been able 
previously to access the System/Administration menus, but after i 
installed HAL again from source i was able to enter the menus which had 
been previously responding with a " you are not authorised ,blah , 
blah...." message.

Now everything seems to work fine. My usb flash is presented in full 
glory on my desktop the same as my cdrom.

Anyway  I noticed that even now the hald man pages are missing...


More information about the freebsd-gnome mailing list