Gaim broken after Glib 2.10 upgrade

Jean-Yves Lefort jylefort at FreeBSD.org
Wed May 3 03:20:38 UTC 2006


On Tue, 02 May 2006 23:09:02 -0300
Rainer Alves <rainer.alves at gmail.com> wrote:

> After updating Gnome to 2.14 and Glib to 2.10, GAIM is now broken and 
> segfaults whenever I try to establish a connection. Rebuilding all gaim 
> dependecies didn't help.
>
> [...]
>
> [Switching to Thread 0x82502e0 (LWP 100113)]
> 0x286cb9d7 in g_slice_alloc () from /usr/local/lib/libglib-2.0.so.0
> (gdb) bt
> #0  0x286cb9d7 in g_slice_alloc () from /usr/local/lib/libglib-2.0.so.0
> #1  0x286cbdd9 in g_slist_prepend () from /usr/local/lib/libglib-2.0.so.0
> #2  0x286ce18c in g_strsplit () from /usr/local/lib/libglib-2.0.so.0
> #3  0x28eae47d in msn_command_from_string (string=0x0) at command.c:60

You have found yet another gaim hole. The argument passed to
msn_command_from_string() is null, but that function does not accept a
null string. I suggest you alert both the gaim people and the FreeBSD
port maintainer.

-- 
Jean-Yves Lefort

jylefort at FreeBSD.org
http://lefort.be.eu.org/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-gnome/attachments/20060503/d5f61fd3/attachment.pgp


More information about the freebsd-gnome mailing list