inkscape strikes again

Csaba Henk csaba-ml at
Fri Jun 24 12:19:35 GMT 2005


Browsing the archives, I've seen that inkscape became problematic in
FreeBSD since they rely on Boehm GC.

For me, I can compile it just fine on my 5.4-RELEASE, but the prog can't
start up. Using the port as is, I just got a coredump. Looking at the
backtrace, there were various points where the prog blew up, but in all
cases, it was related to pthread.

So then I disabled pthread support (recompiled boehm-gc using the
appropriate config settings + deleted -lpthread from LDLFAGS of the
CONFIGURE_ENV in the inkscape Makefile).

Now I see things like:

Emergency save activated!
Emergency save completed. Inkscape will close now.
If you can reproduce this crash, please file a bug at
with a detailed description of the steps leading to the crash, so we can
fix it.

(:27978): GLib-GObject-WARNING **: cannot retrieve class for invalid
(unclassed) type `(null)'

If I run it in gdb, the following backtrace can be seen after a

(gdb) run
Starting program: /usr/ports/graphics/inkscape/work/inkscape-0.41/src/inkscape 

Program received signal SIGSEGV, Segmentation fault.
0x79617272 in ?? ()
(gdb) bt
#0  0x79617272 in ?? ()
#1  0x290a0470 in g_hash_table_lookup () from /usr/local/lib/
#2  0x290a042a in g_hash_table_lookup () from /usr/local/lib/
#3  0x2909a482 in g_quark_from_string () from /usr/local/lib/
#4  0x082d3758 in sp_repr_new (name=0xbfbfe8f0 "inkscape") at xml/repr.cpp:54
#5  0x082ce8ad in sp_repr_svg_read_node (node=0x84e6f20, default_ns=0x0, prefix_map=0x8582f20)
    at xml/repr-io.cpp:278
#6  0x082ce586 in sp_repr_do_read (doc=0x851dea0, default_ns=0x0) at xml/repr-io.cpp:188
#7  0x082ce0f1 in sp_repr_read_file (filename=0x862a3a0 "/home/csaba/.inkscape/preferences.xml", default_ns=0x0)
    at xml/repr-io.cpp:87
#8  0x0817545b in inkscape_load_config (filename=0x83fec13 "preferences.xml", config=0x866917c, 
    skeleton=0x83ff2c0 "<inkscape version=\"0.41\"\n  xmlns:sodipodi=\"\"\n  xmlns:inkscape=\"\">\n  <group id=\"window\">\n    <group id=\"menu"..., skel_size=7158, e_notreg=0x83febf6 "%s is not a regular file.\n%s", 
    e_notxml=0x83febb0 "%s not a valid XML file, or\nyou don't have read permissions on it.\n%s", 
    e_notsp=0x83feb88 "%s is not a valid preferences file.\n%s", 
    warn=0x83feb3c "Inkscape will run with default settings.\nNew settings will not be saved.") at inkscape.cpp:631
#9  0x08175665 in inkscape_load_preferences (inkscape=0x84fe3a8) at inkscape.cpp:673
#10 0x081752ff in inkscape_application_init (
    argv0=0xbfbfecf0 "/usr/ports/graphics/inkscape/work/inkscape-0.41/src/inkscape", use_gui=1) at inkscape.cpp:572
#11 0x0816a150 in sp_main_gui (argc=1, argv=0xbfbfebfc) at main.cpp:354
#12 0x08169f95 in main (argc=1, argv=0xbfbfebfc) at main.cpp:305

Is there any trick/hack/patch which can make it work? Can it be that these failures are specific to my setup? Note that I tried to use the package on another box and it segfaulted there, too.

Couldn't/shouldn't this port be gracefully marked broken for a while?


More information about the freebsd-gnome mailing list