glib trouble

Markus Hästbacka midian at
Sun Jun 20 06:13:04 PDT 2004

I was trying to compile glib this other day and came acros with this 
[16:07:42] root at midi:/usr/ports/devel/glib20# make install clean
===>  Vulnerability check disabled
===>  Extracting for glib-2.4.2
>> Checksum OK for gnome2/glib-2.4.2.tar.bz2.
===>   glib-2.4.2 depends on file: /usr/local/bin/perl5.8.2 - not found
===>    Verifying install for /usr/local/bin/perl5.8.2 in 
===>  Vulnerability check disabled
===>  Extracting for perl-5.8.4
>> Checksum OK for perl-5.8.4.tar.bz2.
>> Checksum OK for BSDPAN-5.8.4.tar.bz2.
Looking at this now seems sane, but let me do a few commands after ^C:ing 
out of that:
[16:10:12] root at midi:/usr/ports/devel/glib20# which perl5.8.4
[16:10:20] root at midi:/usr/ports/devel/glib20# which perl5.8.2

So the problem seems to be that glib wants perl 5.8.2, which doesn't 
excist in ports anymore, and that way tries to install perl5.8 (which 
currently is version 5.8.4). And even that all those perls are installed 
on my system glib wont compile because there's no 
/usr/local/bin/perl5.8.2, and will not ever be one.

The conclusion is that glib depends on the wrong version of perl.

Hope this helps.


More information about the freebsd-gnome mailing list